Can't update wordpress

Username (e.g. epiz_XXX) or Website URL


Error Message

An automated WordPress update has failed to complete - please attempt the update again now

This happens any version and this case is the process for 5.9 to 6.0

After starting update, the process seems to stop at Unpacking the update for more than a hour.

Downloading update from…

The authenticity of could not be verified as no signature was found.

Unpacking the update…

I can see file under wp-admin folder by FileZilla.
However I can’t find debug.log under wp-conntent folder

I have been able to update it if I use another free server service. The process is successfully finished in .

Use Softaculous to update. You can also use ftp.

Did you add these to the wp-config.php?

define( ‘WP_DEBUG’, true );
define( ‘WP_DEBUG_LOG’, true );
define( ‘WP_DEBUG_DISPLAY’, false );
@ini_set( ‘display_errors’, 0 );


I did.And I can upldate if I use FTP.

I’d like to know is how to solve updating problem that happens as I use wordpress Dashboard.

Update via this method does not work well here. It tends to break the website.
Is best to use Softaculous to update or below method

It’s also better to disable WP auto-update. Add below code to the wp-config.php

/** Stop WP update*/

define( ‘WP_AUTO_UPDATE_CORE’, false );


@KangJL, Thank you for telling how to install via FTP.

However, I’ve already known this and once done by this way.

I’d like to know is why or How InfinityFree service doesn’t allow wordpress upload via its admin interface including any major update and miner revision update.

For example ,some PHP module isn’t enabled yet.

1 Like

I believe it is allowed in the first place. It’s just that the time taken to update WP has exceeded the maximum time limit allowed on free hosting. Earlier version of WP updated just fine

Take note WP files have gotten bigger through the years


Thank you for your advice.Yes, I have same idea that you are mentioning.

However, I haven’t seen the following PHP message so far that typically shows us if the process was too much long .
Fatal error: Maximum execution time of 30 seconds exceeded

I think there is any other reason for hanging update process.

  1. The wordpress zip file is more than 20mb.
  2. Max file size on IF is 10mb.

I think it is impossible to unzip zip file greater then 20mb.
That’s why it got stuck at

“Unpacking the update…”


Fair enough. Thank you so much .

There are a lot of topics regards to File Limit.


To be honest, we’re not sure either why it doesn’t work. We’ve tried bumping the script executing time limit, we’ve tried bumping the execution time limit, none of it seems to have any effect. WordPress installations can fail sooner than the PHP time limit would suggest, and they fail without any output, which makes it really hard to debug.


Thank you Admin,

I’m witnessing that the wordpress process can obtain ZIP file into its wp-admin folder but can’t unzip it.

Your MONSTA file management tool also have same problem that the extract functionality can’t unzip any ZIP files even its size is 5KB.

I hope you’ll have an investigation regards to unzip process on your server.

MonstaFTP is suitable for uploading many files, unzipping zips, or moving many items.

This is why we recommend FileZilla.
If you are trying to update WordPress, my suggestion is to

  • use the Softaculous App Installer or
  • download the zip from and then
    unzip it locally on your pc, then upload the extracted files via FileZilla.

Maybe, maybe not. We already have a 10mb file size limit, and many zips are over that limit.

1 Like

Thank you for your comment.

I’m pointing that MONSTA can’t unzip 5KB zip file that should be small enough.

1 Like

I do agree. However, it is not powerful software, but it is better than net2ftp which only allows you to upload, download, delete and edit files, compared to all of the other tings you can do with MonstaFTP.
While I do think solving this would theoretically be a good idea, I think in the long run, it would just be a waste of time.


I think in the long run, it would just be a waste of time.

I agree too, I’m waiting for some one in some day solve it.


MonstaFTP being able to extract large zip files is just not going to happen. Like the name suggests, MonstaFTP is just an FTP client. And FTP doesn’t support extracting archives on the server. So if you tell MonstaFTP to extract the file, MonstaFTP has to download the zip file, extract it locally, and upload the extracted files one by one.

This is exactly the same process as if you would extract the file with FileZilla, except that FileZilla can upload up to 10 files at a time, which MonstaFTP cannot do.

And we have already investigated the WordPress installation/update issue many times without success.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.