Can't send POST requests to my website

Website URL (but I’ve had this problem on every domain I’ve tried)

Error Message

Indefinitely loading

Other Information

When I attempt to interact with my website in a way that requires the transfer of information from something like a login form, the webpage simply loads forever.

Hi and welcome to the forum

I have successfully registered on the forum and made a post

without any problems…

Try logging out of the admin account
delete the browser cache (CTRL + F5 )
close the browser and start it again and log in to your forum and see if it helped


Thanks for trying it out! I couldn’t seem to even get past the terms of service without it hanging forever. I did restart the browser and delete the cache, but had no luck fixing it. I was never even able to get into the admin account.
Could this be caused by a proxy service of some kind? My computer is managed under my school and hence has a proxy service (iboss).

1 Like

I was able to successfully log in to the administrator account by using another machine on a different network (through a proxy). DOes this mean that my school network is blocking the requests in some way? I got these same results with Wordpress and other Softaculous-installable server software.

1 Like

Most likely. Perhaps your school proxy has a sort of adblock-related function which blocks some scripts from loading, and prevents your website from functioning correctly.

The browser could also be an issue, did you try connecting on the same network (your school-managed one) on a different browser? If you manage to connect via a different browser an extension or setting in the browser that doesn’t work could be the issue as well.

Interestingly, I find out I cannot connect via HTTPS to your website because I get an SSL protocol error. Is anyone else facing this?
The following article can help if so:


Unfortunately, I won’t have access to one of my school computers that can use different browsers until tomorrow, and the Chrome they put on the regular ones is heavily restricted. I’m in the process of obtaining an SSL certificate, as I don’t have one as of right now. Perhaps that would fix the issue?

1 Like

install ssl cert or try without https , that should work.

1 Like

Hopefully, if the issue is that your school enforces secure connections then it might help.
Can’t hurt to have an SSL certificate anyway.


Thank goodness. It seems as if adding the SSL certificate fixed it. Thank you all so much for your help!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.