Can't run Laravel project after it was properly deployed

Guys, I am just practicing in web development. I need to deploy a laravel project on infinity hosting.
So, here are some facts:
My website URL is:
What I’m seeing is: 500 HTTP Error
*What I did: copied the whole folder (all together with node_moduls and vendor folders) of a project to hosting

Now it looks like this:
as you can see there are 2 folders in root (empty htdocs and main folder of my site with everything in it)

Can’t figure out, why I keep getting 500. When I use index.php with “Hello” message - is everything ok, I see this message.
Have you any ideas what to examine first? env file?

because index.php in folder is nothing unusuall

Locally my site is functional.

HTTP ERROR 500 means the code is crashing. This article has some pointers to help you get started:


well thank you. Now I can see the error at least. And that’s strange, on my localhost I don’t have this error. What does it mean? Google?

one more thing - what should be in env file for APP?

APP_ENV=  ? 
APP_URL=   ?

p.s. Is there a terminal on hosting ?

problem was: didn’t perform composer update
Now I can see the website, but with some new problems such as no pic at start site, no login/register pages.

I would guess that the vendor folder is incomplete.

APP_ENV is whatever you want it to be. But since this is the live site, I would enter production here.

As for the APP_URL, that should be the base URL of your website.


thanks. But as for not working login and register + no welcome picture, what should I check?
I do not believe that this hosting can’t handle laravel project, especially, when there are only 3 small files of code.

Three small files of code and MASSIVE framework which was definitely not intended for use with regular web hosting.

I see you’re not using my recommended .htaccess snippet, and appear to have butchered Laravel’s directory structure to make your website work. Next to the fact that this is a huge security problem (seriously, you should update any passwords currently configured in your application), this is a rabbit hole to fix.

I had this discussion a few weeks ago with someone else who had trouble running Laravel. Maybe some of the information there can help you too?


Thank you one more time. Editing .htaccess helped to fix all the bugs )) Login/Register is functional and the picture is available, but when a user tries to login or register or forgot password I get 500 server error… Is that .env config? .htaccess? Cause I can see all data in DB

Did you check Laravel’s error log file for more information? Because that should tell you more about what caused the error.


Log file says:

(PDOException(code: 1045): SQLSTATE[HY000] [1045] Access denied for user 'epiz_25827935'@'' (using password: NO) at /home/vol7_7/

Oh God that can’t be true, now I have a blank screen instead of homepage… I didn’t do anything…

Please read this article to troubleshoot MySQL errors:


got it, thank you.

Right now I am trying to debug new error:

The Process class relies on proc_open, which is not available on your PHP installation.

apparently I found a solution, which I wanted to try out, but I get this after I try to upload a 1 kb file:


Does it really mean, that I am not able to upload any files anymore ?

You should remove unwanted files and folders.

1 Like

There are no unwanted files or folders, only laravel framework (145 mb) and files for website (2 mb)

I just checked a vanilla Laravel installation. It’s less than 5000 inodes, including vendor folder. So you’re not uploading “just the framework”.

However, I do not upload the node_modules folder to the account. I compile the CSS and Javascript off-site, and only upload the generated files. A node_modules folder quickly grows to tens of thousands of files and hundred of MBs of disk space, which is a lot for a folder which Laravel doesn’t use at all.


Interesting! Thank you
Tomorrow will try something with node modules.

All right, I think this is the last try, cause it’s getting embarrassing for me.

I’ve managed to get rid of proc_open error, solved problem with space (deleted node_modules folder), corrected env file.
The last thing I get such an error:

include(/home/vol7_7/ failed to open stream: No such file or directory (View: /home/vol7_7/

Cannot find this lib:


But as we can see it is there:

Found in Internet solution (do LOCAL composer install/update/dump-autoload and then upload changed files/folder in project to host) didn’t help at all.

But local is functional even with backslash


Ok, I found the bug… my God… it’s Http, not http

so changed this line




and it worked.

I thought it could also be different php versions. I found that it was a case in almost same situation for other person.

1 Like

If this worked on your own computer before, am I correct to assume you’re building the site on a Windows or MacOS computer?

On Windows and MacOS, file names are not case sensitive. But our servers, like almost all hosting servers, run Linux, which does have case sensitive file names. So the folders http and Http are actually different.