Can't restore backup

Hello, I have backed up all of my files and exported the database. I have created a new account and then uploaded the files. Created a new database, imported the backup. I then edited the wp_config accordingly. When I go to my domain it shows as blank. What am I missing please? I also tried a differnt way, installing WordPress and then just copy over wp_content folder/edit config and drop tables and imported backup with the same outcome. Should I be doing this in a different way?

I did look here Moving WordPress « WordPress Codex
Only thing I haven’t done was use a back up plugin tool.

try this and maybe get a clue

Thanks! There is an error, but I don’t understand what it means.

Fatal error : Uncaught Error: Call to undefined function wp_initial_constants() in /home/vol1_6/ Stack trace: #0 /home/vol1_6/ require_once() #1 /home/vol1_6/ require_once(‘/home/vol1_6/ep…’) #2 /home/vol1_6/ require_once(‘/home/vol1_6/ep…’) #3 /home/vol1_6/ require(‘/home/vol1_6/ep…’) #4 {main} thrown in /home/vol1_6/ on line 41

1 Like

during the initial check WP is not able to initialize
because there are missing certain files or accurate configurations

it can be a little problem…or you will have to do this problem

Alright, with Finezilla I was having some issues. There is only 2 workers for one, I was having a bunch of errors when downloading. So I have downloaded SmartFTP. It has 255 workers. I was able to download htdoc in minutes.

After uploading, I edited the config but now I have a white page again. I can’t see any errors.

I think that is limited for 30min so please use debugging again

I have. It’s white page. My database password is the one I use for logging into cPanel as my account says correct? I really don’t know whats going on lol. Everything match’s up including the table prefix.

What I’m going to try next again is delete all of my files in htdoc, install WordPress through Softaculous, copy over with all of my backup files, drop the database tables, import my backup database, and edit the config. Am I doing this right?

Alright now I’m getting Warning : mysqli_real_connect(): (HY000/1045): Access denied for user. Where do I get my database password if its not my cPanel password?

This is from mysql database page in cPanel. When I change the host from to I get a blank white page.
DB name: epiz_23451053_culture
User: epiz_23451053
PW: (Your cPanel Password)

My only guess is that there’s something up with the DB host getting a ddos or I have no idea now? o.O

I checked your site and so far I’ve seen two issues.

The first issue was with the database connection. The database name, username and password were all correct. Which leaves only one more configuration value: the database hostname. Your account is linked to sql306 but your configuration tried to connect to sql206. I took the liberty to edit the single digit in your configuration, and the database error is gone now.

Right now, it shows a blank page, and returns a status code of 200, which means OK. With WordPress, this usually means one thing: your settings are referring to a theme which is not installed. You can see the themes installed on your website by checking the htdocs/wp-content/themes/ directory.

To check which theme is currently configured in your website, you can do this:

  1. Go to the control panel of your hosting account.
  2. Go to phpMyAdmin and launch it for the database of your WordPress site.
  3. Click the table in the list which ends with _options.
  4. Click the Search tab at the top of the page.
  5. In the table, find the row which contains option_name and enter the search value template. Leave all other fields blank and click Go.
  6. The currently activated theme is the value in the column option_value.

If the activated theme does not match the directory name in the themes folder, you’ve activated a non-existent theme.

To fix this, you can either:

  • Edit the database row and change the option_value column to match one of the folders of themes which are installed.
  • Check your backup for the missing theme folder and upload it to your account.

Hmm, not sure why the backup didn’t take the theme. I have uploaded the correct theme showing in the database. I still have a blank page. How do I check the status codes like you did?

I can see that plugin folder was missing too so I uploaded it. Now I have a bunch of mysql errors hmm.

Alright I deleted the problem plugins, the errors are gone. It seems the backup/upload skipped loading a bunch of files/folders hmm…

I can’t figure this out.

Well I said screw it and went back to the old server. lol Thanks for all of your help guys.

Well I went back to the new server. For some reason some files didn’t go when I uploaded. I had to hunt them out and upload them manually (mostly plugin folders/files). I’m stuck with this error and cant figure it out.

Fatal error : Class ‘WP_List_Table’ not found in /home/vol1_6/ on line 2090

Line 2090 reads:
class TGMPA_List_Table extends WP_List_Table {

What do I do? I’m thinking there’s a file missing somewhere.

1 Like

The simple solution would be to not use that theme

I have no insight into your files but I can assume your theme uses TGM-Plugin-Activation

contact the theme author and possible fix
source Fatal Error on plugin activation |

If your theme or plugin no longer needs TGM Plugin Activation
remove Frequently asked questions - TGM Plugin Activation

other PHP message: PHP Fatal error: Class 'WP_List_Table' not found in - Juzhax Technology

You can see the HTTP status codes by checking the Network tab of your browser’s developer tools.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.