Cant log in with Firefox


When I use firefox the following message appears and I cannot log in. It seems to be because of TSL 1.2 (with another browser (Tor) it works.

Error: Secured connection failed

An error occurred when connecting to PR_CONNECT_RESET_ERROR

The website cannot be displayed because the authenticity of the data received could not be verified.

Please contact the owner of the website to inform them about this problem.

(other information and details relevant to your question)


  • What Firefox browser version you are using? Is it updated or outdated? Most outdated version seems have bugs of it according to what i read.



Ich use Firefox 79.0 (64 bit) the newest version of Firefox. Firefox has only recently been updated and so far it has always worked.


I just realized that I can also log in with Opera.

Did you try to follow the article link i’ve posted? :slightly_smiling_face:

1 Like

Generally, You should do what Digi said and read the article, however I myself have had some issues like this WITH firefox & Other Browsers, Generally, and browser running Chromium would have issues (Chrome, Firefox). But this is caused by anti-malware blocking the site, and injecting their own SSL certs to prevent the page loading, It is a man in the middle, preventing the site from loading, it could be anti-virus or firewall

There is security software like Avast, Kaspersky,
BitDefender and ESET that intercept secure
connection certificates and send their own.



First I entered the host address:

  1. [] - Grade B

  2. [] - Grade B

3. [] - Grade B

Then I changed security.tls.version.max from 4 to 3, but I still can’t log in with Firefox.

Then I went to and checked the TSL version. The answer:

Your SSL client is probably OK - Version GOOD - Your client is using TLS 1.2


I’ve tried everything possible now. WLAN checked, Malware adwcleaner_8.0.7. but nothing helped. I use Opera now, because I can log in with it.

Also, That is a fix, but note the website is not .com, Have you disabled antiviris? It might be blocking website, maybe at network level



I tried it again with, I probably had before, but nothing has changed. I will just use another browser then.

I don’t have much more to do anyway. I just wanted to upload my yoga and meditation pages anyway and I am almost done with that.

I wanted to register these pages at, but you need to have a top-level domain for that. But I don’t have one. Do you have any advice? Thanks for your help.

Yeah ok, and if you want to register at I recommend using FreeNom, free unlimited domains (


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.