Can't install any WordPress plugins

It seems like it is some memory issue, because the plugin gets stuck on “unpacking the package…” forever. I can’t even install it manually.

I’ve tried doing some things that some tutorials requested me to do, and it still won’t work. I checked out the panel and I didn’t even use 20% of the Inode, so I have no idea why it is not working, it must be a server issue.

What can I do to fix this?

What plugin you want to install? If it’s over than 10MB, it will automatically deleted and WordPress will “panic” about it.

That’s also the same reason why it’s not recommended to update WordPress through dashboard. :wink:

WooCoomerce (it is 9 MB). I’ve tried to install a random plugin just in case it’s some WooCommerce issue but the same thing occurs, I don’t really know what to do lol.

Hmm, since it’s almost 10MB, you may not be able to install it through dashboard, and you need to do it manually

1 Like

I have installed WooCommerce here before, and it has worked fine for me. Are you installing it though the “Plugins” panel in WordPress Admin?

1 Like

I did try to install it manually via uploading the ZIP file on the WordPress admin panel, and the same thing happened. I can’t upload the entire plugin using filezilla or smth because it has literally 3K files, and I guess you can’t upload that huge amount of files.


Unzip the plugin’s zip file, then upload it’s folder to wp-content/plugins directory.


THAT WORKED! Thank you…


You’re welcome. I did the same because of same problem :cry:

1 Like

Memory limit are exceeded or syntax error or wrong file format?

We’re not quite sure, actually. It could be the file size limit, it could be script time limits or script memory limits. All we know is that installing big plugins doesn’t work for some reason.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.