Can't create tables in phpmyadmin

Cue Well Snooker (epizy.com)

Please forgive my if in the wrong thread as I’m a first timer here. Also first time I’ve worked with mysql database and phpmyadmin

I created a db, then tried to add my first table. After entering all details, I click the Save button, but nothing happens.

This is what I see if click the Preview SQL button -

CREATE TABLE `epiz_32459765_cwsdb`.`bookladdermatch_form` ( `id` INT(20) NOT NULL , 
`date_fld` DATE NOT NULL , `time_fld` TIME(20) NOT NULL , `challenger_fld` VARCHAR(20)
 NOT NULL , `opponent_fld` VARCHAR(20) NOT NULL ) ENGINE = MyISAM;

I deleted the db, logged out of everything, cleared my cache, logged back in, created a new db, added a table again and clicked the Save button, but still nothing happens.

Any ideas what is wrong?? or suggestions on how I solve the issue??
I’m a 65 year old guy who has next to no knowledge when it comes to php and databases : )

Does it print any errors? That SQL code is correct, so I can’t imagine what’s stopping you. Can you possibly try from a different browser (sometimes things like this happen, and trying in a different browser clears it up, it’s quite odd).

It’s OK! That’s why we’re here! And there’s no age limit to learning and knowledge :slight_smile:

3 Likes

Thanks for your speedy response. I switched from Edge to Chrome browser. First thing I noticed is that the db remains created, but the table was not there. So I added the table again via Chrome, but after clicking the Save button, still nothing happens.

Here is the SQL query error -

SELECT * FROM `bookladdermatch_form` WHERE 1 LIMIT 0, 25

MySQL said:

#1146 - Table 'epiz_32459765_cwsdb.bookladdermatch_form' doesn't exist

Hello!

For the record, you are in the correct spot, good job!

Try this:

  1. Open PHPMyAdmin in the control panel
  2. Select the database you want to use to open it
  3. Select the “SQL” option in the top navigation bar (Should have a magnifying glass icon)
  4. In the text box, paste the below code:
CREATE TABLE `bookladdermatch_form` ( 
`id` INT(20) NOT NULL, 
`date_fld` DATE NOT NULL,
`time_fld` TIME(20) NOT NULL,
`challenger_fld` VARCHAR(20) NOT NULL,
`opponent_fld` VARCHAR(20) NOT NULL
)
  1. Before you click “Go”, wait a few seconds and see if any red X’s appear to the left of the text input
  2. Click the “Go” button located in the lower right hand corner
  3. It can take some time for the DB to process your request (My current record is about 5 minutes, but normally is around 20 seconds).
  4. You will either get an error message in red, or a success message (It says something like “Query Success”)
  5. Close the tab, and re-open it from PHPMyAdmin in the control panel
  6. You should now see the new table

If you get an error or it still does not work, let me know!

3 Likes

I believe I have solved the issue after receiving the below error. I changed the Time from 20 to 5 and table is now added.

Here’s the error -
CREATE TABLE bookladdermatch_form (
id INT(20) NOT NULL,
date_fld DATE NOT NULL,
time_fld TIME(20) NOT NULL,
challenger_fld VARCHAR(20) NOT NULL,
opponent_fld VARCHAR(20) NOT NULL
)

MySQL said:

#1426 - Too big precision 20 specified for 'time_fld'. Maximum is 6

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.