Can't create SSL certificate

Username - proedge

Error Message

Can’t create SSL certificates using both ZeroSSL and GoGetSSL.

SSL certificate error: An unknown error occurred. Please try again later.

Other Information

I was using SSL for past one year without any issue but now I can’t create new one
ZeroSSL says: SSL certificate error: An unknown error occurred. Please try again later.
GoGetSSL: Got stuck on the creating certificate page

But I tried external ZeroSSL and it worked fine!
Is the integrated SSL broken? Will it be working again ?

No, I believe it is hit by the rate limit.

You can probably try next week


What’s the rate limit? Is the rate limit related to my account or the whole Infinityfree network ?

Read below. It should give you a better idea


Your GoGetSSL order is not “stuck”, it’s waiting for you to complete the required setup. The CNAME record is missing for it. And GoGetSSL orders can take some time to process (half an hour is not unusual). If you want the certificate, please set the CNAME record and leave it until the certificate has been issued.

ZeroSSL is a whole different story. The API on their system we communicate with is EXTREMELY slow many times. My guess it that they are rate limiting our access to them, but more investigation is required to say for certain what the cause is.


I did configured cname records and got verified SSL provider. Waited 2 days for that certificate… Nothing happened

Then I deleted cname records and configured for ZeroSSL from their website… It worked like charm

~Is this happening to others ?
Or I needed to consider external options

I checked the current status of your order at GoGetSSL. It seems like the order status is still “processing” at their end, but the description field would suggest an error occurred on their end and the order is not going to be fulfilled.

I did deploy some changes yesterday that might make our ZeroSSL integration a little bit more stable. But their API isn’t working very well for us.

Let’s Encrypt hasn’t given us any trouble like that, but their rate limits make it impossible to provide Let’s Encrypt certificates for free subdomains.

The reality of the situation is that there aren’t many providers that are able to provide SSL certificates in bulk for subdomains.


A post was split to a new topic: SSL Cert Error

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.