Can't connect to FTP even after using IP

Hi I can’t connect to FTP. I’m a developer of 20 years, so this is extra frustrating.
I’m using port 21, and I tried using, ftp.epizy(dot)com, and as the server address and nothing works.

I get the error message “Login failed. 530 Login authentication failed.”

I copied and pasted my username and pw exactly. And I even tried the [email protected], and that didn’t work either (that works sometimes). Any ideas?

This is likely your case


Thanks but that wasn’t my problem. i didn’t know the system automatically set up a separate password for the FTP account. When i created it, it made it seem like my vpanel account PW was also the FTP PW, so I had to go on a hunt for the FTP account settings and found out there was a PW automatically set behind the scenes. Thanks though! It’s resolved.


The VistaPanel password is the FTP password. But please note that VistaPanel is the thing accessed on Our client area,, is not VistaPanel and has it’s own login system.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.