Cant add MX record

My website URL is

I made some mistake when adding an MX record (inexperience) that I tried to correct and now I cant add any MX record, it does not let me add anything. I do not see any error messages, just stand still doing absolutely nothing, do not advance and add nothing. What do I do now to add the MX record?
So far I have just installed a few plugins to see how they work with the softaculous installer. Learning.

Waiting for help.

Thank you

For it doesn’t show the MX record, so you’re OK. You need to add the MX record with MX server and priority of 10.

Thats what i´m trying to do, but when i click in add nothing happens he blocks and stays like that he doesn´t do anything doesn´t add anything. Maybe because i tried to remove the MX register that was in there in the beggining and still is “” in the earlier mistake. What should i do now?

Thanks for help. and are the same record, but the panel does things that iFastNet fixes after 8-24 hours they received the order for it. You can add your domain (either buyed or got from Freenom or and set the MX record to it, or check this article for more informations.

I just tried to add the MX record to your domain, and it worked without any problem. No message (both good and bad), but the MX record was set up. Did this solve your problem?

Undoubtedly, registration is already added there, thank you very much for the help (s).

Thank you again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.