Can't Access My Website

My website domain is

when i try to visit it says took too long to respond i need help i just added site to infinityfree and can’t access it

for me. it shows the default welcome page. it looks for you it’s a DNS Problem:

1 Like

so its nothing wrong with you maybe? hmm i wil ltry that fix

But now it’s showing a weired after 1-2 seconds it then shows loading screen with text this will only take a moment please wait why its not dislaying my site?

Do you have enabled cloudflare?


when i visit my site with www it works fine but when without www it shows weired page ? help

It shows me

1 Like

my website is redirecting to and showing this page:

For me it works. Try to follow these instructions.

1 Like

but why its not working for me??? it’s showing advertisement LINK!!!

Because of DNS caching, it’s not working for you.

how can i solve that problem? i tried flushing dns still showing advertisement link but when i visit site using www it works ? :thinking:

For me it works both way. Maybe your Internet DNS cache takes too long to update. Try to:

  • Clear your cookies and browser cache;
  • Configure a faster DNS resolver (like on your device.
1 Like

i also tried visiting from another device but not working is that router problem? already cleared cookies and cache nothing fixed :thinking: and what you see after you visit my site without www ?

The page loads, and I can see a default InfinityFree welcome page.

so all i need is to wait ?


1 Like

Yes, or try to re-do the steps above.

1 Like

ok thanks

1 Like