Can't access my subdomain


I created a subdomain ( ) on my website, but the page is not showing. I put a simple “Hello world!” page on the website as well but still nothing, but I tried going to the page on my phone and a Network Advertising Initiative page appears. I know that these pages will appear on subdomains that don’t exist but I know for sure I created it and was able to upload files to it. Does anyone know a solution?


Hello there,

This is what your site looks like at my end:

Have you already tried clearing your browser cache?

1 Like

Yes, I’ve tried multiple times. I did add that redirect to and it’s working on your side, but still not on mine.

Can you try clearing your browser cache one more time?

If issue is still persistent you can try the following:

  • Flush your local DNS cache
  • Use a VPN
  • Visit your site using Incognito Mode
  • Use a public DNS resolver like the service from Cloudflare.

It’s still not working, I even went to my CPanel and removed the subdomain, then added it again.

Did you really try all those solutions I gave you??

I also suspected that it’s your ISP’s problem that their DNS cache still had not yet updated/refreshed.

Please take not it takes a few minutes to a few hours until a new subdomain will work properly.

Yes I did. I used the ipconfig /flushdns command in Command Prompt, and still not working.

Did you try using a VPN? Did you also tried to use another Web Browser? Did you also tried to use a Public DNS resolver like Cloudflare’s or Google’s DNS??

Also as what I’ve said it could be a problem with your ISP’s DNS cache or just a problem with you local device.

I wasn’t able to configure the resolver, and I don’t have a VPN.
When trying to setup, it tells me I need a subnet mask.

Your site is also working from here, so that clearly means it’s an issue on your end, not on the hosting side (if it was a hosting issue, nobody would be able to access your site). In that case, removing and re-adding domain names is the last thing you should be doing, because that will just make things worse and take longer.

The reasons are explained more in this article, with workarounds:


Ok, thank you!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.