Cannot get ssl certificate, cname error

**My website URL is:**

**What I’m seeing is:**The CNAME record is not pointing to the right destination. one is working

**I’m using this software:**wordpress, chrome

**Additional information:**one CNAME IS READY BUT OTHER IS NOT, before i used to have ssl certificate from cloudlare u guys messed up my website, it was stuck in redirect loop forever, now i deleted whole account and started fresh, new account.
name server are
NS1.EPIZY.COM and NS2.EPIZY.COM, there should be five should i change and fill all five, second my account is i put correct CNAME still its not accepeting.

i also changed name servers to and so on…
not ready yet to give ssl certificate.

finally i am in process to get my ssl certificate, it took some time so if someone else see this thread please be adviced that process takes some time so please wait and in end hpefully u will get your certificate. i hope these issues will not happen again in future related to ssl. thank you infinity free, awsome work introducing free ssl certificate.

lastly every effort failed, i tried to upload the certificate it says its not for my website,

The private key you are trying to upload is not valid.
i tried only uploading key

if you are using cloudflare. you must add the CNAME in the DNS setting in cloudflare. make sure it is not proxied (DNS only). then wait until it is verified in the control panel.

Did you copy the full text from the Private Key box in the client area? Including the full lines with the “—BEGIN PRIVATE—” and “—END PRIVATE KEY—”?

1 Like

no i didnt included all line, but now i did firstly put private key with line at start and end and then certificate , now there is no message that certificate uploaded or key uploaded.i run my website no https.

i am using cloudflare too, so i off the ssl from clouflare as i am geeting it from infinity free, now what changes should i do in cloudflare to get ssl.

If using cloudflare add the CNAME in dns of cloudflare. Then wait till both are verified. Once verified, upload the private key and certificate in your cpanel. Then enable ssl in cloudflare (full or full strict).

1 Like

Disabling SSL in Cloudflare completely disables all SSL on the sites proxied through Cloudflare. Cloudflare can’t fall back to using the SSL certificate on your hosting account, because Cloudflare doesn’t have access to those.

You could disable the Cloudflare proxy by making the orange cloud in the DNS records grey.

1 Like

The connection has timed out. my wensite is not loading it is showning this, i did all what was told, now whats the issue.

The server at is taking too long to respond.

i think certificate is uploaded, do i have to produce CSR key too, if so how to do it.
my website is not opening, still its shows no ssl certificate, why?

i think mt page rules were interfearing from my site to load i off all of them, now y site is loading but still no SSL. what to do, should i delete cloudflare account for my website, still is there any assurance that ssl will be activated.

got ssl working, i just had to install ssl really plugin in wordpress and it automatically activated https over my website now, https are working on both wordpress and my website in chrome.

my website only working on chrome browser, aprt from this my website is not loading on phone, safari, firefox etc, still i dont have ssl what is going on.

Finally everything is working, actually the problem was i wa not putting my address properly i guess, the thing is when i put simple it should lead to my website but it was not loading only white screen comes, when creating wordpress site i put http and www. to denote at staring of my website, so when i load my site with it loads perfectly fine with all browser. hope this will help all.

1 Like

A post was split to a new topic: Me how many days it took to activate SSL certificate on your site