Cannot Generate SSL Certificate


So i am setting up a website for a friend of mine.
And, we have proper hosting, but i use InfinityFree for SSL (bcoz the hosting provider we have charges like 30$ a year for SSL certificate, hell no)
And now i’m trying to get an SSL for the domain, it doesn’t work
cPanel says it’s not for the domain we are trying to install (
And after some digging, InfinityFree generated a completely null certificate
Meaning that it doesn’t link to any domain.

Please fix it.

Since you’re using a different hosting provider, how do you expect InfinityFree’s SSL system to work for your domain? InfinityFree is a website hosting, not an SSL provider.

If you’re looking for free SSL tools here are some you can try out (including services that InfinityFree’s SSL tools utilize): / SSL Certificate Generator: Free letsencrypt SSL in minutes - PunchSalad (Let’s Encrypt)
GoGetSSL 90-day Trial SSL for best price of $0.00/year


Please make sure the SSL generated is for the correct domain.


It is for the correct domain
InfinityFree didn’t generate it properly

Since you say “we have proper hosting” that is not infinityfree (currently Linode)

the first question is why you are not using Cloudflare certificates ?
because your domain goes through Cloudflare NS


you can have a flex cert on CF…

for full mode, you should also have a cert on origin (which is self-signed)

for full strict you need to have a valid certificate on origin

if you completely decide for this hosting
then you need to route the domain through CF DNS
to lead to the IP assigned to you by this hosting


and then, depending on the CF settings, choose the certificate you want to have and which will be installed on this hosting


btw. HTTPS version

but the above has nothing to do with us because you are technically not our user at the moment



I already fixed this
I caved in and got to use Certbot on the VPS and it works.
InfinityFree is better for me but it works i guess
Still, i can PM you the certificate i got for the domain (I tried ZeroSSL, GoGetSSL AND Let’s Encrypt and it didn’t work, all were with different errors though)

Also i don’t like proxying the website tru Cloudflare coz i host other websites on it and alot have large files which my Free CF account won’t let me upload

I see you’ve tried everything
until you finally succeeded in that hosting


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.