Cannot download .php file to ftp server

Please help me when I upload a .php file on an FTP server ( site/andftp/powerftp they write that the operation was completed successfully, but the .php file still does not appear, how can this be fixed? (Sorry for bad English)

It could be a file size limit

The InfinityFree web servers have size limits for all files. If the file size exceeds the limit, the file is automatically deleted.

The size limits are:

HTML and PHP files are limited 1 MB.
.htaccess files are limited to 10 kB.
All other files are limited to 10 MB.

Please note that this is a file size limit, not just a PHP upload limit. All files on your account are subject to this limit, regardless of how you’re trying to get this file on your account.

Another reason could be that certain file types, like .exe and .pdf files, are blocked on InfinityFree for security and fair usage limitations. Regular website files are allowed, but other files may be blocked.

Thanks Admin and Team for this information :+1:


Thanks for the answer, but, unfortunately, this is not the reason, even a 38b file does not upload to the server

1 Like

Can you use a desktop FTP client like FileZilla? If it still fails, please share the full FTP logs


On all FTP clients the same thing, “file uploaded successfully” but I noticed that the .php file appears for a few milliseconds, but then disappears, I found a slow solution to the problem - change the file resolution first to .txt, and then back, but on the server.

that is strange, can you post the file here using the “</>” code tag or upload the .txt version and post a link to it here, I would like to upload it to my hosting and see what happens ! its possible that you may have discovered a glitch oO


I tried to make gdps, Of course, using my method I was able to download these ( files, but I will be glad if you help me.

I extracted the zip and uploaded the folder to my I.F. hosting and had no issues
Files are there and correct (see pic)

I used filezilla with transfer type set to auto (default)


Hmm, strange, I used filezilla on my phone, I’ll try it on my PC, thanks in advance.

Here’s another video of how this happens (

you are uploading to root and that video shows you are uploading a .exe file , both of which are not allowed !

files should be uploaded to the htdocs directory


Before this, I tried to upload files to a non-root folder, so this is unlikely to be the problem, and what’s also strange is that I can upload .exe files, but I can’t upload .php ones

Files have to be uploaded to the htdocs folder, please try it before saying that it is not a solution.

If it still get deleted, check if your inodes or disk is full


Yes when I upload files to a folder htdocs files are not deleted, but I would like the folder to be called database, because in this case it is easier to edit the .apk file to replace the server with mine. By the way, can I ask one more question? To specify the database in the file, I need to specify the server, port, login, password, but I don’t know which port to specify, is it possible to specify port 3306?Or is it not possible to connect?

You can store APK files here either, InfinityFree is not a web storage provider.

Also, I don’t think FileZilla has an official smartphone application.

Can you record a video uploading a PHP file to the htdocs folder? That’s what your problem is about … right?


Yes, problem solved, All files are uploaded to the htdocs folder without problems. Thanks for the answer.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.