Cannot create a product using WoocommAPI

Username (e.g. epiz_XXX) or Website URL

epiz_32218009 / (my website url on the link on the bottom of this post)

Error Message

Hello everyone.

I’m trying to create a product in my store using the WooCommerce API but I can’t. I’m performing a POST to this URL: and sending my consumer key and secret on the Basic Auth option. When I send the product payload into the JSON I get an HTTP 200 with an HTML of response (in the link on the bottom of this post). I also tried to send the same request with an OAuth 1.0 and nothing changed, tried another API endpoint, tried on different days, tried GET and POST, etc… nothing is working! Please, what can I do?

I’m testing through an HTTPS website, hosted on InfinityFree, with WooCommerce Version 6.7.0 and WordPress version 6.0.1, also with pretty permalinks set (using the ‘Post Name’ one).

Other Information

I was in contact with WooCommerce API and they provided me some information and also asked me to get in contact with the InfinityFree support, so here I am!

In this link you can check all the links of the information above:

That is because of the security system:

Unfortunately, this means that you cant use the WooCommerce API.


Oh, sad.

Ok, thank you for the information anyways!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.