Cannot Connect to FTP Server

When I try to log into FTP account I can’t. Tried almost every FTP client but failed. Note that I did update the password and tried login. No success. Login credentials are correct but the problem stays the same. FYP my username is - epiz_33898187

Well, “It does not work” is not very helpful. What is the actual error message?


My Bad. Here is the Verbose output.

Status: Resolving address of
Status: Connecting to…
Error: Connection timed out after 20 seconds of inactivity
Trace: CFtpControlSocket::ResetOperation(2114)
Trace: CControlSocket::ResetOperation(2114)
Trace: CFtpLogonOpData::Reset(2114) in state 1
Error: Could not connect to server

Well this issue is on your end.
Tried vpn or other types of internet connection?

1 Like

Yeah this only happens in my Laptop. Other PC and Mobile devices can access the FTP server w/o any issues. Can’t figure out why tho.

Check firewall rules?

1 Like

See some of the later points in this article:


Seeing how the connection IP address is correct, and the connection fails during the initial connect stage, not later, a firewall rule dropping FTP traffic would make the most sense. That could also be from a virus scanner or other security product.

I don’t think the FTP ALG settings have to do with this. Trying a VPN is always an option, but if your laptop and PC are on the same network, that might not work either.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.