Blank page after uploading amended index page

Here’s the file Dropbox - index.htm - Simplify your life
As I said, it is the same one I have been using from the start so there should be nothing wrong with it. If it is missing coding then it must be when I upload it, but I’ve never had that problem before.

It’s working for me, so something must be going wrong when you are uploading it. Can you try opening the file (Editing it) from the online FileManager?

2 Likes

I checked your file. It’s not using UTF-8 encoding, and has some characters which are not valid UTF-8 characters. This is why it cannot be opened in the file manager, and likely why either the server or browsers cannot open it.

Please re-save the file with UTF-8 encoding and upload that instead.

I don’t know why it worked before or why it doesn’t work now. But I can tell you that text encoding is a huge mess and makes my head hurt, and I know that as long as you use UTF-8 consistently everywhere, you don’t need to worry about anything else.

5 Likes

Yes, it is fine online. I can open it in editor, and all the coding is there. See below for example:


(Apologies for the delay but I used up my 12 hr quota yesterday.)

I should not have to change the encoding as page was working perfectly before. Also, other pages with the old encoding still work fine on your server,so that cannot be the problem.
Also page can be opened in file manager (for editing, etc.), as above example shows.

the admin has said that the system requires uft-8 encoding and thats what you need

you may have been lucky before that the page was loading but now you are having issues so why not make it utf-8 and fix the problem ?

4 Likes

You came here asking why your site doesn’t work. I told you what I think is the reason and the solution.

If you don’t want to try my solution, that’s your call. But I cannot help you if you don’t like my help or won’t accept it.

The reason why I think it’s an encoding issue is because of weird glyphs in the file, like on like 56:

I’m not sure what this line looks like for you, but it doesn’t look OK for me.

5 Likes

Right, so my mate and I had some fun over the weekend trying all sorts of different tests, including uploading his own page from his site, as well as some basic UTF-8 encoded pages, and guess what? None of them work. We concluded, someone or something is blocking the pages from showing. It has nothing to do with me or the encoding. The problem is with the server.
Please advise.

If you really think its the server, then delete the hosting account and create a new one.

3 Likes

Thanks for that, but won’t I lose my domain name?

Not if you remove it from the account first.

3 Likes

Mind sharing some of those test pages so I can check?

All I can see is that the index.html file you uploaded before is corrupted or incorrectly encoded. I don’t know for sure when or why this file got corrupted.

Now you mention uploading other pages: how are you uploading the pages? A broken or misconfigured FTP client can also corrupt data as it’s being uploaded.

2 Likes

The file you mention is one of many that we tried, including basic html, but the interesting thing is we uploaded my old index page to his site and it worked perfectly. I always use Filezilla (which is the latest version) and I’ve never had any problems with it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.