Allow_url_fopen is not enabled!

I have seen other topics about that and it didnt work for me. my php script needs Allow_url_fopen to be enabled. tried with perfex crm-server requirement and it shows this…

and the script im trying to install requires Allow_url_fopen to be enabled! attatching a screenshot of that too!!

main hosting link:
PHP script link:
Perfex crm link:

allow_url_fopen is a big security risk. For our safety and yours, it cannot and will not be enabled.

From Insufficient Transport Layer Security (HTTPS, TLS and SSL) — Survive The Deep End: PHP Security :: v1.0a1

Of course, the allow_url_fopen setting also carries a separate risk of enabling Remote File Execution, Access Control Bypass or Information Disclosure attacks. If an attacker can inject a remote URI of their choosing into a file function they could manipulate an application into executing, storing or displaying the fetched file including those from any untrusted remote source. It’s also worth bearing in mind that such file fetches would originate from localhost and thus be capable of bypassing access controls based on local server restrictions. As such, while allow_url_fopen is enabled by default, you should disable it without hesitation to maximise security.

Please ask the developers of your software to fix their code to not have to rely on security risks.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.