Access denied for user 'epiz_24390141'@'' (using password: YES)


How to resolve Access Denied for user ‘epiz_24390141’@‘’ (using password: YES)

I already read, but could not solve

Are you sure you’re using the correct password and database name? Remember that the database password is the hosting account password, which is different from the one you used in the Client Area!

If these solutions couldn’t help, and you changed the hosting account password recently, the database password sometimes is not synced to all the databases, and you need to wait for the Admin to reset the database permissions.

as I know what the hosting password is, I only know the client area

You can find the hosting account password by logging into your Client Area, selecting the hosting account, scrolling down to “Account Details” and clicking on “Show/Hide” to show the password. You can use it to login to FTP and use databases.

yes the password is right, and the error

Is the error the one you posted before? If not, please post the new one.

not giving asseco denied error

Are you sure you’re using the right password? I posted a guide on how to find the hosting account password. If it doesn’t work, then it’s most likely that you changed it from the precedent one, and you need to wait for the Admin to reset the database permissions.

sure, i’ll wait for admin to change the permissions

I just tried to login with the actual details of your account, and I didn’t get any database errors. So this is not a database permissions issue. Just make sure you use the database name, username and hostname from the MySQL Databases section, and use the hosting account password from the specific hosting account you’ve created the database on (you may want to rename one of the two identically named accounts to help signify the difference).

That said, the installation fails because the data directory is invalid. Our hosting has security restrictions in place to prevent scripts from accessing files outside of it’s own website directory, and OSSN requires it’s data directory to be created outside it’s own website directory. So that means you cannot host OSSN with us (hence the reason why it’s not in Softaculous).

1 Like

[quote=“Admin, post:12, topic:20110”]
a instalação falha porque o diretório de dados é inválido. Nossa hospedagem tem restrições de segurança para impedir que scripts acessem arquivos fora do seu próprio diretório de sites, e o OSSN requer que seu diretório de dados seja criado fora do seu próprio diretório de sites. Então isso significa que você não pode hospedar o OSSN conosco (daí a razão pela qual ele não está no Softaculous).
[/quote] Oh ok, I didn’t know that OSSN wasn’t premeditated

But Elgg is allowed?

Elgg also needs its data directory to be outside of the htdocs folder, but we can’t allow it. So you can’t host Elgg the same way as it was on OSSN.


1 Like

Check your config.php
See if the password quoted there is correct.

I got the same problem before, after i corrected the password, problem solved.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.