About Freenom and InfinityFree

I am new to using Freenoom. I have created a new free domain: “strap.ga” but I have several questions/doubts:

  1. The name-servers I have to have in the Freenoom client area are: NS1.EPIZY.COM and NS2.EPIZY.COM right?
  2. When I access to strap.ga, it redirects me to “http://www.freenom.link/es/index.html?lang=es”, is this a good sign?
  3. Can I configure Let’s Encrypt as SSL certificate and install Cloudflare? What is the risk of using both/any services?


Freenom is glitch’y nowadays, they don’t even accept contacts from their free customers.

  1. use other free providers like nic.eu.org
  2. collect money and buy a domain from namesilo (or any providers)

Sure, cloudflare installs trackers on your website if you enable in on your website. (it is to say who’s visited your site and where they’re from. and some other statics)


So I don’t have to wait but Freenoom didn’t install right or something?

yes, it’s been like this since a year ago in my experience.

1 Like

I thought I had to wait for the domain to be activated… thanks for the help! :frowning:


works neatly test is here
but you did a redirection to strap.42web.io and it is currently suspended

what you have experienced is (it happens with every change of NS)

And why am I being redirected to a website that I have disabled?

can you be explicit please

what did you disable ? name? URL?

what does your browser display?

do you have any notice in the Client area?

Problem solved! Thank you very much :smiley:

1 Like

easiest for you is to redirect (301) strap.42web.io to strap.ga (what kind of GD do you mention? )

I managed to solve the problem. It turns out that I downloaded a backup of my previous app and when I tried to deploy it to a new website, it had the wrong links configured. Thank you very much for helping me! :slight_smile:


You’re welcome - I need some time to connect everything in my head
but you solved the problem quickly

good luck in further work

1 Like

ok to summarize :joy:

you created a domain on Freenom
your browser, (PC, router, all the way to the ISP) when visiting that domain
is retained DNS data which led to Freenom
because you had the default NS of Freenom in the beginning and it was not hosted anywhere

after alternating NS

your browser still had old data and sent you to the Freenom page

after a while, the browser pulled fresh data and directed you to the correct IP

but you deactivated strap.42web.io because it was problematic (it leads to suspended page)

so I was asking you just in case to see if you have any message in the CA in case it is really suspended

after realizing that there is a redirection
due to the old default URL on the old backup
the new website was trying to access an address that was deleted (I suppose)

and then you corrected it

and now you’re on Cloudflare

and you have problems with redirection loop

if it is WP


You missed “now he’s in the chair waiting for his Let’s Encrypt certificate to be generated” HAAHAHAHA how scary.


you don’t need it if you use a Cloudflare certificate

1 Like

I sent you a message but one of the CNAMEs went from “ready” to “not ready”. I don’t know how to generate the SSL with Cloudflare :frowning:

choose FLEX (and make sure your domain is in the orange cloud )


you don’t have much to do there
just !switch the button!
and then wait


Okay, the state is like that:

Do I delete the CNAME records I added for Lets Encrypt?

a lot of changes and even my browser no longer knows what the real state is :roll_eyes:

NS leads to CF - ok

please let it all settle down for a while
and do that for WP from the article above
sit down and read in peace
put it all in your head and then go take action

You can


Okeey. I’m going to wait a while and see if it fixes itself, everything on CloudFlare seems to be green so I think there is no problem. I don’t use WordPress by the way.