522 error from Cloudfare

About a day ago i forwarded my domain to cloudfare for SSL. It was added and i recieved the confirmation emaill from cloudfare in about 5 minutes :slight_smile:

I added the NS for this site at cloudfare, but now 12 hours later i am still recieving these 522 errors from Cloudfare.

Is this simply a propogation issue? I havent waited long enough?

Looking forward to anyone’s feedback:0)

Thanks!!! :0)

Could you try adding the screenshot again? It doesn’t look like the upload worked.

I corrected the image (add ! in front)

Also, i added the two Namerservers for infinityfree , ns1.epizy.com &
ns2.epizy.com, with no others.

The screenshot shows the result when i try to add the domain. Perhaps i should also add the 5 Nameservers in the screenshot also??

i just read in one of the messages that the nameservers ns1.epizy.com and ns2.epizy.com have been having problems (under attack etc…) this month. I think i will delete them and add the 5 Byet nameservers…maybe it will resolve the issue

Your domain leads to Cloudflare instead to this hosting (NS)


Thanks, i have my own domain and i’ve been trying to add it…(please see screenshot and infos above), the problems are all in the screenshots. it won’t resolve…

I can only repeat what I said before
Your domain currently leads to Cloudflare instead of our NameServers.

And when you fix that - wait a few hours and then add a domain here in the system
(and then optionally you can use CloudFlare again)


ok thanks. yes i tried that already. and was waiting for 2 days and it didnt resolve.

I need SSL, this is why it’s now pointing to cloudflare… for the SSL

Then ill point it from Cloudflare to infinityfree

I got an error message in Cloudflare " Your domain will not resolve. An A, AAAA or CNAME record was not found for the www subdomain."

So i need please an IPV4 address for infinityfree.
(i need to add an A record in cloudflare)

I can’t find an IPV4 address anywhere in my control panel here…

But,…i will try as you suggested again, and change the DNS at the registrar and do the waiting game again…, and afterwards try it with the Cloudflare thing, once the domain has resolved properly.

I just changed the nameservers in my domain control panel to:


let’s see what happens…


Congratulations - It’s all right now :slight_smile:

You can start to upload the files in domain/htdocs/ here

And when you’re convinced that everything works with your website…you can add your domain to Cloudflare for HTTPS as you stated before

ok thanks, i uploaded all the files days ago to domain/htdocs/

im just checking it all now

The domain is resolving to the file manager…

1 Like

i think i’ve found the problem… the last time i uploaded it all went to the subdomain directory…not the directory for my own domain

i will upload all again

You’ll have to edit the source code
Because you use some files from XY.epizy.com

yes that was my question im just editing the source now.

So the images are all under the directory : http://english.ventures/ ?

Not only pictures but also JS etc. Looking at EPIZY.com

please use browser dev.tools F12 (console or network tab + refresh)

ok thanks i’m fixing it all now so all is working with the new directory

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.