500 Error, please check your php script / enable display_errors in your cpanel

Website URL

(please specify the URL of the site on which you are experiencing the problem)

500 Error, please check your php script / enable display_errors in your cpanel

(please share the FULL error message you see, if applicable)

Hello! Could you please return the settings that were a month ago on this site in terms of php or whatever you spin there? Our website does not work. Everything used to work, but you seem to have updated something and everything crashed. Please correct it if possible. Thank you!

(other information and details relevant to your question)


We updated our PHP version to 8.2 as our previous version had reached its EOL date. Please check the display errors box in the control panel under PHP config, then reload your website to see the exact error.

If you need an older PHP version, please upgrade to premium hosting


Maybe we will pay you with bitcoin and you will fix everything as it was before the update?

Hello, since your are able to pay, I recommend you to upgrade to premium hosting. You get a lot more features, and also a PHP Selector which allows you to go back to PHP 7(which is the previous version)


Hi @Greenreader9 , I noticed the same issue yesterday october 1st 2023. I did enable the php display_errors in cpanel and the error message is still “500 Error, please check your php script / enable display_errors in your cpanel”.

Wordpress is not logging any errors. The last log was on september 29, 2023.

Since that error is generated server-side, and not browser-side, the problem is surely in the .htaccess file inside your website’s htdocs folder, so check it for any line that could cause that problem.


what kind of line should i look for

Can you share your website’s URL?

Have you also enabled WP_DEBUG as instructed in the relevant article?

Share your entire .htaccess file if possible, format it with ``` around the code so it’s easier to read, so like this:



@ChrisPAR I can only share my URL in a browser screenshot if you wish to validate what I’m saying. I requested for my URL to be removed in a previous post and it was declined. I do not wish to have too many links in Google index pointing to my pages about issues in my website.

This is my wordpress logging confguration:
define( ‘WP_DEBUG’, true );
define( ‘WP_DEBUG_LOG’, true );
define( ‘WP_DEBUG_DISPLAY’, false);
define( ‘SCRIPT_DEBUG’, false );

I do not think the error is from .htaccess file. The site was running perfectly well until the PHP 8.2 upgrade. I did not anything at the backend before the crash.

Ironically wordpress is not logging, the last error message was on 29th September. The error “500 Error, please check your php script / enable display_errors in your cpanel” is a server error message.

The /?i=1, /?i=2 at the end of my URL is part of Infinityfree security.
I found explaination at Why do I see ?i=1 at the end of a URL

If only the browser can display the error code we can get to the root of the issue. I don’t know how many websites that may be affected by the upgrade.

Would it still be possible to share its contents, just to be 100% sure?

That message typically was an indicator of a .htaccess problem. Could you please try renaming the .htaccess file to something else and see if that removes the error? It only takes a minute and will get us off your back about it.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.