413: Request entity too large

Hello, when I am viewing the file manager (and attempting to upload a .zip file) it gives me a “413: Request entity too large” error before the file can finish uploading! Does anyone know how I can successfully upload the file? I’ve tried just uploading it and uploading as well as unzipping and either way, it still gives the error!

Hello and welcome to the forum!

Can you please provide the size of the file?

1 Like

Please unzip the file locally and then use FileZilla. 413 Request Entity Too Large is a HTTP Protocol error not FTP Protocol error.

Also follow this guide if there are any errors from FileZilla:



How do I do that?

Please note that there is a 10mb file size limit on all files. You can either…

(A) Reduce the size if the file (Or unzip it if it is a compressed file)
(B) Switch to a different hosting provider that does not have a limit on file upload size.

Please let me know if you have any questions!


Ok, so unzip it, THEN upload the file?

On windows, right click and select “extract here”. On other os, follow this guide:

1 Like

Yes, drag and drop as usual! You may also wish to create a folder and place them in there for order and cleanliness.


Really? It says if running Linux to type the command Cd Downloads into the terminal! I tried that and this error was returned

Screenshot 2021-12-14 2.59.07 PM

Now, I’m using Chrome OS and Chrome OS is Linux! So why is it returning that error? Did I type in the command wrong or what?

So I COULD also take the file, create a folder and put file by file into the created folder?

Crosh is not a Linux terminal! However, you can install a Linux Virtual Machine to run in Crosh.

You would need to unzip it first. You can’t upload a 57 MB file here. Follow this (How to Zip and Unzip Files on a Chromebook | Digital Trends) to unzip the file in ChromeOS and then drag-and-drop into any folder of your choice.


Is it really?


It looks like it uploaded more than 10MB!

Yes, but it will automatically deleted.

1 Like

So it’s useless and I HAVE to lower the file size?

I will say it again: You can’t upload a file that’s greater than 10 MB. It won’t retain in the filesystem because it’s too large.
If you can unzip the file, then upload it and it will be there. Then you can download that directory and zip it again if you wish.
Otherwise, use a file sharing service, such as Mega.nz.


Doesn’t the “Upload and unzip” option do that?

What type of file are you trying to upload?

Also, remember that the online file manager is an online FTP client, it does not work as well as desktop FTP clients.

Try unzipping the file (If it is a compressed file) on your own computer, then uploading it.

If the file is not a zipped file, you cannot host it here.


It is still recommended to upload the file before unzipping it locally on the computer

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.