404 We couldn't find that page SSL installed but still unsecure

**My website URL is:**http://www.iamblackdeath.ga/


**What I’m seeing is:**my webpage is not working i have done all the things posted on the form

I’m using this software:

Additional information:

For me it works fine. try to clear your DNS and browser cache!

also rename index (2).html to index.html~!

sir try www.iamblackdeath.ga
or iamblackdeath.ga

rename index .html to index.html !

1 Like

done, still not working

How it doesn’t work? try to upload your files completely!

Your website should have a filed called index.html (or index.php or index.htm), which is uploaded DIRECTLY to the htdocs folder. So the file should not have another name, and should not be uploaded to a subdirectory, or the server will not be able to identify the file as the main file of your website.


CERT is fine

Mixed content


of course do what @Admin and @anon19508339 told you


what should i do i have a ssl licence from sslforfree but not working

even my site stop working


everything is fine on my part

Now it’s up to you to redirect all traffic from http to https

It is likely that you still see the old state (related to SSL)… why?
Note that some browsers cache SSL certificates for a very long time. Can you try to use private browsing mode to open your website? Private browsing basically circumvents all cache.


still not working

Try to clear your dns and browser cache.

1 Like

I can see your website but other online tests can not (depending on location)
it may be DNS propagation or (again) it may be a special problem with DNS servers.
We ask you for your patience


so you say i should wait

yes, for now it would be best to wait, then we will check how your website looks like around the world after a few hours.
Thank you for your time


Thank u for your quick response

1 Like

and now you changed NS to cloudflare :roll_eyes:
Nevermind… it’s getting harder for me to keep track of all your changes :smile:


thank u it’s working now but i have another issue when i try to connect my ftp it shows an error
421 3900 users (the maximum) are already logged in, sorry
how ever i try to use online file manager but it also not working

This is down for while.