ZipArchive() doesn't work in my account

Username (e.g. epiz_XXX) or Website URL

epiz_25260657

Error Message

I don’t know. it just doesn’t work

Other Information

It works in another account but it doesn’t work in epiz_25260657. I think it is a sever error.

Thanks

And I tried to run

$zip = new ZipArchive();
$filename = "test.zip" ;
if ($zip->open($filename, ZipArchive::CREATE)!==TRUE) {
    exit("cannot open <$filename>\n");
}
$zip->addFile("index.php");
$zip->close();

this code

Please recheck your file path and name. Also, make sure the zip size is less than 10MB for Infinityfree.

Is this another account on Infinityfree or somewhere else?

1 Like

I checked aready and I see it return true.

Please make the above changes and try again.

Sorry for late respond. I tried to do that but It doesn’t work still. Also, other code that work last week doesn’t work either. I guess it is a sever error. But thanks for your respond.

Could you please try a bit of debugging for yourself first? Do all the function calls execute? Do they all return the value they are supposed to? If the function doesn’t work, there should be some indication that it doesn’t, and not fail silently.

4 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.