Your connection is not private

Username (e.g. epiz_XXX) or Website URL

Error Message

Your connection is not private

Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards). [Learn more]


To get Chrome’s highest level of security, [turn on enhanced protection]

Other Information

I am trying to install SSL certificate for my website, but it’s not working properly. Please help me.

Your SSL certificate is working exactly as intended. You requested and installed an SSL certificate that was “Self Signed (not trusted)”, which clearly said in the comparison table that it was not trusted by web browsers. You installed this certificate successfully, which as you can see is working as intended, because the certificate indeed isn’t trusted.

If you want an SSL certificate that’s trusted by browsers, then please request and install an SSL certificate that is trusted by browsers. Simply request another SSL certificate for your domain through the Free SSL Certificates tool, and choose an SSL provider that has a green tick next to the “Trusted by most web browsers” feature. The one that has the green label that says “Recommended” is often the best choice.


Well of course its showing that error. You selected “SelfSigned” on the certificate page, where it clearly states that SelfSigned certificates are not trusted by browsers.

Please generate a trusted certificate from GoGetSSL or LetsEncript.

Also, please use either the “epizy” or “byet” nameserver set, not both.


I installed “Recommended” SSL certificate. How can I delete SelfSigned certificates?

By overriding it when you install the GoGetSSL or LetsEncrypt certificate.

I did, but it’s not working…

I installed another one, but still not working?

Can you screenshot from client area to prove that it’s installed?

It seems you’ve successfully replaced the self signed SSL certificate with a Let’s Encrypt certificate!


Please note the following:

  • It can take up to 15 minutes for a new certificate to take effect.
  • Some browsers cache SSL certificates for domains. The regular options to clear browser cache don’t erase this cache. You may need to verify the SSL certificate through Incognito mode (or just check the installation details in our client area).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.