WordPress Theme Issue?

Isso já foi resolvido ?
não estou conseguindo atualizar o código fonte do meu site através do editor de temas do wordpress.

Please provide more info if you need help



não consigo mais atualizar nenhuma pagina do meu site via editor do wordpress, sempre que tento salvar apresenta o seguinte erro:

“We were unable to communicate with the site to check for possible fatal errors, so the PHP change was rolled back. You will need to send the changed PHP file some other way, like via SFTP for example.”

esse erro começou junto com o problema do “Websites, FTP, and Control Panel Inaccessible”

eu já desinstalei o wordpress e instalei a nova versão porem o problema persiste.

veja imagem de exemplo:

obs: mesmo escolhendo um theme padrão do wordpress o problema persiste.

You didn’t translate it to English, I guess… Please note that this is an English-speaking forum, so you MUST speak in English or at least translate the message. I’m gonna do that for you this time, then for the rest I’m gonna ignore you:

You can try to use the File Manager to edit the file you want to edit.


Edit wp-config via file manager. Add those lines after wp_debug line.

define('WP_DEBUG', false);

define('FTP_USER', 'username');
define('FTP_PASS', 'panel_password');
define('FTP_HOST', 'ftpupload.net:21');
define('FTP_SSL', false);


Did not work.

So I created a new domain from scratch, just for testing, and the same error persists, even with the default wordpress theme.

I noticed that the error only happens when I try to save the pages in .php format

Any idea ? I believe the problem is in the hosting, in the connection between wordpress and hosting.

Error message displayed:

(We were unable to communicate with the site to check for possible fatal errors, so the PHP change was rolled back. You’ll need to upload the changed PHP file some other way, such as via SFTP, for example.)

Did you try making the edits via the file manager or an FTP client instead of doing them inside WordPress?


That sounds like it could be caused by this security system:

Unfortunately, that’s normal, mandatory and cannot be disabled. So I’m afraid you’ll have to edit your files directly through the file manager or FTP.

Or maybe see if it’s possible to disable the Fatal Error check. But judging by the error message itself: WordPress also tells you that you need to find another way to edit the files.


thanks for the feedback and details about the error.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.