WordPress error when saving: "There was an error. You are probably offline."

The same was happening with default theme and plugins.

Did you…?

install the classic editor plugin, enable the classic editor (instead of the block editor)


I just tried multiple themes. It seems to happen to them all.

It seems that, when saving the widget, it tries to redirect to the 404 infinity free page for whatever reason. That request to retrieve the 404 page is blocked due to CORS policy.

I do not understand what is causing the WordPress to throw the 404 error.

In addition to my other fix attempts, I changed the time zone to match the one I am in as that seemed to cause issues for other members. This did not fix it for me.

As last resort, try installing WP on a new hosting account.
Screenshot what you did along the way. Do not leave out any important details

I already did that when I first had the issue.

New Account > App Installer > Wordpress > Install

Those were my exact steps.

You are out of luck then. Try WP forums

So frustrating this is, especially after trying all the fixes that helped majority of people.

I shall post there and respond here if I get a solution, wish me luck!


Good luck!!

They got me to install a plugin which found the issue:

“Error encountered: (0) cURL error 60: SSL certificate problem: unable to get local issuer certificate”

It is a issue that they are unable to fix.

This is not an issue but rather a limitation of free hosting


Not being able to save a widget is a limitation of free hosting? Doesn’t that render the point of free hosting null if you are unable to build websites on it.

Thanks for all your help by the way.

In terms of the first post, that is not a error I am getting. However, I shall try the fixes on both and get back to you.

Fingers crossed!

The first solution, about the certificate not being trusted, is not the issue. See here:

“This warning can be safely ignored. While it’s true that some browsers may not accept your SSL certificate, almost all modern browsers on all devices do. You can be sure that 99% of all devices that have been updated in the last five years can see your site without any problems.”

I have tried it on all modern browsers and every single one gives the same issue.

I believe the CORS error is the issue. As the Admin said, something is causing the page to redirect to InfinityFree’s 404 page which causes the CORS issue.

Which is a pain for me as I have no links on my site.

I did notice that they said this in the second post:

" * AJAX requests from other websites (CORS). AJAX requests are only possible on the same (sub)domain."

I believe this is the issue. The browser wants to display a 404 from InfinityFree through a AJAX request. However, since its not on the same sub-domain it just fails.

Now to figure out what is causing the 404 call. Seems to be a bug on InfinityFree side.

It is definitely the AJAX request to the hosts 404 page causing this. The above error is what will be thrown when a outside AJAX call is made, according to the second article.

So far none of us is having this issue, except you. So it is difficult to pinpoint where the problem is…

Can you screenshot this error, maybe from the developer tools??

1 Like

I have finally figured it all out.

On a free hosting plan, you are unable to make widget calls through the Appearance menu as that, for some reason (maybe a bug), then throws a error 404 page which requires a external AJAX call which is not allowed. Meaning, you can not take the below route to make widget changes:

Appearance > Widgets

You have to do it through the Customize menu, which edits the widgets whilst your on your homepage looking at them. Meaning, you have to go through this route:

Appearance > Customize > Widgets

1 Like

Which plugin? Is it called “Health Check & Troubleshooting”?

Because if so, you’ll see the API loopback check failing. That’s normal, and as far as I know almost all WordPress sites hosted with us have this error but work fine anyways.

Happy to hear you were able to resolve this!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.