Why does my root domain throw a 404 error but with

My website is https://www.martinluer.ml

Error Message

There are 2 errors, 525 (SSL handshake error, I see it when I toggle full SSL in cloudflare)

Other Information

Added domain to infinity free with register NS, then changed to cloudflare NS (and removed IF ones)
I have the right ip / main domain added (Have tried with cname and A records in CF) but when I go to root domain (martinluer.ml) it always gives a 404 error in infinityfree’s website.

If i enable full SSL, it gives 525 error, okok, but the URL changes from martinluer.ml to www.martinluer.ml (Because of page rule, like I want it).
If I dont enable full SSL, it throws 404 without changing URL, this is my problem, I dont mind about full SSL, I just want a functional website that redirects root to www and doesnt return 404.

my page rule is: martinluer.ml/* → 301 → https://www.martinluer.ml/$1

ty in advance.

Messed up title, sry

Works for me



Omg, im so angry, I was trying things for 2 days straight, even made another IF account to test if it was glitched or whatever, it never worked. I THOUGHT i was deleting my browser cache, then because of ur comment tried it on incognito and it worked, im so AHH, welp, eitherway thank you.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.