What happened?

The WooCommerce Inbox is not working, any fixes?

As of now, this is not a problem (but if I have an order), I have to email the customer about the notes for the order.

“There was an error” is a very helpful error message.

What is the actual error message?

Add this line to your wp-config.php file:

WP_DEBUG flag: define (‘WP_DEBUG’, true)


@Greenreader9 do this thing uses the “chat” keyword so it is blocked by Infinity Free?

No, if it is an email inbox, it won’t work because IMAP is disabled on our servers. If it used the chat keyword, you’d see a 403.

1 Like

But I have changes everything to SMTP. Using a plugin.

anyways, I enable wp-debug on Softaculous. Let’s see the results.

Yes, but SMTP is Simple Mail Transfer Protocol, emphasis on Transfer. SMTP is only for sending mail, not receiving.
IMAP is used to receive mail, as it is Internet Message Access Protocol, emphasis on Access.

I personally don’t think WP-Debug will solve this issue. I think it is just the underlying server configuration.

It never is. It is in the main directory, in your case htdocs.


I disabled the debug on Softaculous and will find a solution to this. Maybe a plugin again. My problems and headaches are always solved by plugins, hopefully this time it will be the same.

I don’t think you can solve this by adding a plugin, and generally, that is a less-than-ideal mindset.
I don’t know if it was you or another user complaining about how slow Wordpress is, but adding more and more plugins will just make it slower. And slower. And slower.

I don’t think that you’ll be able to solve this by adding another plugin, or enabling WP-Debug. And as I clearly stated,


I guess it will not be solved by plugin because my problem is a known issue of Woocommerce now. But all of my plugins I have here (12) solves all of my problem: Security, Preloader Animation, Customization, Analytics, SEO, Emailing, WooCommerce, PHP RAM Monitoring and Optimization. As of my testing, if a plugin is not running in the background then it will not affect its performance as I have seen.

My WordPress Website ranks A so I am contented with it. Even not to reach A+.


Hi, I made a brand new wordpress installation with woocommerce and flatsome theme (all current versions). There are no other than the flatsome required plugins installed. At the woocommerce main admin page I get an error: “There was an error getting your inbox. Please try again.” How can I fix that?

Temporary (or maybe Permanent) Workaround:
Just message the customer via email.

@wackyblackie Can I change the server time presented in my plugin. Its 10:06AM here while its 2:06 in the server.

How to configure WordPress date and time settings (a2hosting.com)


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.