Website worked, now redirects to ad

Good morning! I am trying to redirect to:

It worked for a little over 24 hours (yay!) but now shows an ad for infinityfreeapp. My html files, which worked at the free address, are still loaded in htdocs. I don’t know if they are not being accessed or if they are just not being shown.

I have basic ftp and html knowledge, but I’m out of my league here. Any tips or suggestions?

I see both websites showing some cars. The custom donain doesn’t redirect to the subdomain. Clear your cookies and cache.

Thanks for your quick reply! Very weird, as it works on Firefox but not Safari. I cleared my cookies and cache and still get the ad on Safari desktop and on my iPhone.

It also doesn’t work in a private window… still shows the ad.

The redirect is working correctly, and I do see the ads (Called a “Parking Page”).

How long ago was the subdomain added to the account?

Also, why are you redirecting to the subdomain, instead of to the main domain. If you use the main domain as your primary domain, your Google rankings will go up. (You don’t have too, just a suggestion).


Thank you, @greenreader9 for your help!

I own vmotorworks dot com and wanted to try out infinityfree, so I set my domain provider to forward it. That way I wouldn’t need to set any nameservers, etc.

I then uploaded the very basic website folder and index file to htdocs. This simple redirect worked for about 20 hours and then the parking page reappeared.

Makes sense.

I set up the free account around 42 hours ago.

DNS propagation takes upto 72 hours


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.