Website still not secure-Cloudflare is protecting my site

hello fro Greece

well i sign up for a free account at cloudhost, I submit my website , i changed nameservers to cloudflare nameservers but my website is still not secure (lock pad is missing). My website is hosted on infinityfree and i do not know what may cause this problem.I conducted with them,they ensure me that everything works fine from their view. I get the messa ge from cloudflare ‘‘Great news! Cloudflare is now protecting your site’’

any suggestions?

Change the SSL settings to flexible ssl and turn on force https!

1 Like

If I turn https I will lose my webpage I tried it before. Or should I wait some time to be enabled?

I mean I get white protocol error from browser

You need to create an SSL certificate from the SSL/TLS section. and click “Edge Certificates” on the submenu.

Make sure you’ve enabled Flexible mode.

Seeing how you’re using both WordPress and Cloudflare, please make sure your website is set up like this:


thank you for your guidelines, this trick fixed the issue i had with an exception on Firefox browser
when i visit the page using Firefox there is a orange question mark that says part of this site are nit secure like images
This happens only by using Firefox

Oh i had so much issue getting my https working. Is all your image and page saved as https:// ? i had to reupload all my pics . you could test this by making a blank page with no contents and see if you get the padlock.

i hope that helps

The solution is this article. Have you really read it all and follow all steps on what @Admin provided?



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.