Website showing iFastNet 404 error instead of

Username (e.g. epiz_XXX) or Website URL

https://invalidmc.com/

Error Message

We couldn’t find that page.

Please check to make sure you’ve typed the URL correctly.

This webserver is CaSe SenSiTiVe so ensure capital letters in the URL match the files uploaded.

[Go Back](javascript:history.go(-1):wink: 404 tutorials and help

Other Information

I recently moved the domain from another hosting account due to lack of inodes, on the previous one it was working fine, but since moving to the new one, I have been experiencing constant errors when updating various pages.
Sometimes the domain fails to load the page, other times it shows the iFastNet 404 error page (I assume this is a bug as I have always experienced the InfinityFree one). On the rare occasion that the page loads correctly, everything works fine so this confirms that it isn’t an error on my part.
Please help as soon as you can as I need the website running as soon as possible.

Please note that the website may not load using ssl so if the link above dosent work try http://invalidmc.com/

I see that your site is not working when visiting https and you have a mixed content on your site

ERR_SSL_PROTOCOL_ERROR.

Where did you get the ssl? Cloudfare or using the infinityfree tool?

Some links and files are cannot be found on your website manager

Example:
http://invalidmc.com/favicon-32x32.png
http://invalidmc.com/site.webmanifest

Please consider uploading those files into your htdocs. The reason why you get error404 because your website cannot find that file to load and it will redirected to Infinityfree error 404 cause you didn’t setup your own custom error 404.

And this https://invalidmc.com/assets/style.css.

Your css style and other resources that will be loaded in HTTPS might be loaded/cause in error/Error404 cause you use HTTPS instead of HTTP and your HTTPS protocol is error.

it works, i can confirm, but it randomly disconnects and shows a 404, my code is fine

The reason why you get error404 because your website cannot find that file to load (Read above-updated)

1 Like

you seem to be misunderstanding, it was working completely fine until about 1hr ago, i changed nothing

Your HTTPS protocol is error, so you can’t visit some links and even it cant load the .css file. Because you use HTTPS on it

https://invalidmc.com/assets/style.css

Including Home, Forums, Bans.

While your Https is in error, Try to change those HTTPS into HTTP.

And please be ensure that you have uploaded those files/folders into your htdocs to avoid the error404.

1 Like

i have tried that many times, ill change it now to prove that

Yes consider changing those https into http since your https protocol is in error.

and of course now it works, but before, when the style.css was fetched over http, the error was the same, it seems to randomly be happening with no cause, regardless of http(s)

also i have never had a site.webmanifest

Oh, based on my dns lookup, you are using CloudFlare as main dns provider(correct me if im wrong). I notice you dont have any A or CNAME records. These records are important to tell networks where they would go.

Pls make sure you set your A /CNAME records. If not, then add it manually.

For A record,
A => IP address given in your account panel

For CNAME (if you have subdomains),
CNAME => www => @

This may help you.

unfortunately that information dosent explain why its random, as i said in my original post, i had the website up on a different hosting account, there it was working perfectly without the random errors

i also havent changed cloudflare settings since moving

Your website is not accessible to me neither its contents.

Its working fine without error404. The only problem here is your https, when I click on Navigation menu, i get an ssl error.

yea, i made a seperate ticket with cloudflare regarding my ssl status, i have correctly setup the ssl there but it isnt updating, i have yet to get a reply

but i dont really want to have to change the navbar back once it eventually updates so im leaving it as is, sorry for any confusion

I see it, you used 4 nameservers instead of only two

Name Server: CHAD.NS.CLOUDFLARE.COM
Name Server: INES.NS.CLOUDFLARE.COM
Name Server: NS1.EPIZY.COM
Name Server: NS2.EPIZY.COM

Remove that ns1 and ns2 after verifying your domain to infinityfree and leave the cloudfare. So your HTTPS will work fine. Clear your caches and wait for an hour or a minutes.

1 Like

i have that exact configuration on another website and it is working as intended