Web load laravel http 500 error

Website URL

(please specify the URL of the site on which you are experiencing the problem)

Error Message

http error 500
(please share the FULL error message you see, if applicable)

Other Information

no change in config anyway just got error
(other information and details relevant to your question)

Hi and welcome to the forum


i try to download my app to my pc and no problem at all , it works on my pc localhost

this work it after i just update composer with the same php version

this my htaccess file

<IfModule mod_rewrite.c>
    <IfModule mod_negotiation.c>
        Options -MultiViews -Indexes
    RewriteEngine On 
    # Handle Authorization Header
    RewriteCond %{HTTP:Authorization} .
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    # Redirect Trailing Slashes If Not A Folder...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} (.+)/$
    RewriteRule ^ %1 [L,R=301]
    # Send Requests To Front Controller...
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]

Options -Indexes

but anyway sometimes fix it self my web https://eoskominfo.freecluster.eu/forum/public/ , i use uptime robot to monit my web

here i use my localhost it works

Telling us it works on your local environment doesn’t help diagnose the issue. Have you enabled display_errors and any debug settings the software has as mentioned above?


There seem to be more reports of people with Laravel sites seeing blank pages with no errors.

I did some testing to figure out why, and I don’t have the full answer yet, but I have already seen that Laravel 7 and older do not work with PHP 8.2. You are using Laravel 7, which means you need to upgrade to a newer version of Laravel to make your site work with our hosting or any other hosting that uses the latest PHP version.


Thats correct , thanks

after i upgrade to laravel 8 everything is okay


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.