Unable to view my site since today

Website URL


Error Message

Failed to load resource: the server responded with a status of 500 ()

Other Information

Unable to view my site since today.

Sounds like a PHP upgrade gone wrong.
Are you able to do this?


Please enable error messages on the control panel (PHP Config) and reload your page. Copy the error message here.


php is not woking any more, thus no error message from php after configured.
https://f.vyse.fr.nf/tests/t.php with code below has the error message saying php token is Undefined:

<?php. phpinfo(); ?>

Is this code working?

echo "Hello World!";

Yes, https://f.vyse.fr.nf/tests/echo.php working, but phpinfo not working

Expected. phpinfo is blocked on free hosting.

You can try this instead

$phpVersion = phpversion();
$configOptions = ini_get_all();

echo "PHP Version: " . $phpVersion . "<br><br>";

echo "PHP Configuration Options:<br>";
echo json_encode($configOptions);

It seems working, check this:

@KangJL I found a error in upgraded PHP volumn:

@set_time_limit(30);   #set_time_limit is a disabled function
echo 'Hello';

Many PHP project takes care of disabled functions and add @ symbol to ignore any error.
But in PHP 8.2, this @ symbol behavior is not working any more (I’m not sure it’s a PHP bug or config issue).

Under PHP 8.2, @ decorated disabled function causing 500:

Fatal error: Uncaught Error: Call to undefined function set_time_limit() in /home/vol6_4/epizy.com/epiz_31674447/htdocs/tests/echo.php:2 Stack trace: #0 {main} thrown in /home/vol6_4/epizy.com/epiz_31674447/htdocs/tests/echo.php on line 2

You can comment it out using


Yes, after modify, it’s working now, but many app using @, causing compatibility issues.


Disabled functions behave as if they do not exist - PHP 8.0 • PHP.Watch

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.