This page isn’t working..... Please Help

My website URL is: http://www.kpoppnow.com/

What I’m seeing is: This page isn’t working

www.kpoppnow.com redirected you too many times.

  • [Try clearing your cookies]

ERR_TOO_MANY_REDIRECTS

I’m using this software: Cpanel, file manager

Additional information: I don’t have any idea what really happened but my website is suddenly down after rebooting my computer. Please help…i just remembered i edited my webpress theme, im new in hosting and website…

The reason you see this issue is because you setup a redirect through the control panel to redirect kpoppnow.com to www.kpoppnow.com. However, since your website with and without WWW serve the same content, this also causes www.kpoppnow.com to redirect to www.kpoppnow.com. Which of course causes a redirect loop.

The fix is simple: remove this redirect from your account.

If you wish to enforce your website URL with or without WWW, you can find plenty of example of .htaccess rules online on how to do this, as well as instructions on how to set them on your website. Or maybe there is a WordPress setting or plugin to do this for you.

2 Likes

Thanks it works. But another problem again.

What I’m seeing is: This site can’t provide a secure connection

www.kpoppnow…com sent an invalid response.

  • [Try running Windows Network Diagnostics](javascript:diagnoseErrors()).

ERR_SSL_PROTOCOL_ERROR

I’m using this software: Cpanel, file manager

Additional information: I create a ssl account on clouldfare after that i don’t see any changes or security lock on my website. Then i tried to change the HTTP to HTTPS on my website admin and this what happen.

I just checked your website and I see an “Error 525 - SSL handshake failed” error. But the root cause is the same both both your error and mine.

The reason is that you are trying to access the website on your server using HTTPS, but you don’t have an SSL certificate installed. If you want to use Cloudflare, you should configure Cloudflare to use “Flexible SSL”, not “Full” or “Full (strict)”. If you want to use those modes, or want to use HTTPS without Cloudflare, you’ll have to get and install an SSL certificate.

Getting WordPress to work correctly with Flexible SSL can be tricky, but this article explains how to do that:

https://infinityfree.net/support/wordpress-and-cloudflare-flexible-ssl/

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.