Support Request - Error pages.

Summary

I tried to alter the error pages. After altering them and trying them, they don’t work.

Account

http://www.melnsils.rf.gd

Software

InfinityFree Builder to build the website. And VistaPanel to alter the error pages.

Steps to reproduce

Try to make the error pages appear by entering an incorrect URL (e.g. http://www.melnsils.rf.gd/ergg). It shows blank page and text “Error 404” instead of showing my own error page (http://www.melnsils.rf.gd/error404)

What is the current issue behavior?

The error page altering is not working.

What is the expected correct behavior?

I want to see my own error pages when I enter incorrect URL instead of showing that blank page.

Attempted solutions

I tried multiple times to re-alter the pages, but it didn’t help.

The reason your own 404 pages don’t work is because the site builder manages the 404 pages now.

When publishing a website with the website builder, the website builder uploads a .htaccess file which points all non-existent URLs to the website. That’s how the pretty URLs work. This means that your own 404 pages will never be used. And when the website builder site does not know any page with the given URL, it will show it’s own 404 page.

The website builder does not have the option to customize 404 error pages, so I’m afraid you’re stuck with the default pages for now.

@Admin said:
The reason your own 404 pages don’t work is because the site builder manages the 404 pages now.

When publishing a website with the website builder, the website builder uploads a .htaccess file which points all non-existent URLs to the website. That’s how the pretty URLs work. This means that your own 404 pages will never be used. And when the website builder site does not know any page with the given URL, it will show it’s own 404 page.

The website builder does not have the option to customize 404 error pages, so I’m afraid you’re stuck with the default pages for now.

But why they still don’t work if I alter them with VistaPanel?

@Robciks1234 said:

@Admin said:
The reason your own 404 pages don’t work is because the site builder manages the 404 pages now.

When publishing a website with the website builder, the website builder uploads a .htaccess file which points all non-existent URLs to the website. That’s how the pretty URLs work. This means that your own 404 pages will never be used. And when the website builder site does not know any page with the given URL, it will show it’s own 404 page.

The website builder does not have the option to customize 404 error pages, so I’m afraid you’re stuck with the default pages for now.

But why they still don’t work if I alter them with VistaPanel?

Because of how the site builder works. It overrides the error pages of your account.

@Admin said:
Because of how the site builder works. It overrides the error pages of your account.

Is that going to be fixed later?

@Robciks1234 said:

@Admin said:
Because of how the site builder works. It overrides the error pages of your account.

Is that going to be fixed later?

I don’t know. SitePro, who develop the builder, don’t publish a development roadmap so I have no idea if or when that feature will be added.