Subdomain not working

Hello guys,
I hosted a domain here (gramscilab-ales.com) hosting the main web site and it works properly. Then I created a subdomain (villaverde.gramscilab-ales.com) hosting a landing page for an event but this does not work properly. If I try to open it I see something as a default web page, probably a redirection.

  • I am not using Cloudflare
  • I searched the support before to post this message
  • For some minutes it worked yesterday night but now it is not working
  • I activated the domain yesterday, more or less 24 hours ago, the domain worked after a couple of hours
    Thanks, any help will be appreciated.

Your 1st nameserver is set to ns2.epizy.com when it’s supposed to be ns1.epizy.com

Mmmm… I set the nameservers for the domain on namecheap and they are ns1.byet.org … ns5.byet.org in the right order from 1 to 5… where did you saw the others?

@anon95130038 - It does not make a difference.
All NS (name servers) have the same information no matter how you order them.

4 Likes

Seems I have no problems with the domain (gramscilab-ales.com) but only with the subdomain(s) as villaverde.gramscilab-ales.com as you may verify navigating to them.

try adding the subdomain again and wait a few hours
but if it doesn’t help then it’s a question for the admin

2 Likes

Right.

Is there a way to contact the admin? Or do I have to wait he reads our posts here?

try adding it again first

Please wait for him here

1 Like

Now it redirects to http://gramscilab-villaverde.epizy.com …

Because you created a redirect which does that in the Redirects tool in your control panel.

2 Likes

without that it does not reach the subdomain… now I will delete it to see what changes. There is another subdomain residenza.gramscilab-ales.com that is the copy of the other and ahs no redirect. I ca nreach it but it looks bad and different than it shoud be.

The subdomain(s) web page should look as http://gramscilab-villaverde.epizy.com quite different as it looks. Why this difference?

The difference you’re talking about is that http://gramscilab-villaverde.epizy.com/ seems to be a functional web page, but http://villaverde.gramscilab-ales.com/ (which should be the same page) doesn’t?

This is caused by many of the style sheets and other included files not being found. For example, http://gramscilab-villaverde.epizy.com/assets/css/fontawesome.min.css returns a CSS file but the URL 404 redirects me to 404.

It took me a bit of digging before I noticed it. But this seems to be caused by one of the .htaccess rules you uploaded to the latter site. In that file, you have a line which refers to villaverde-gramscilab-ales.com. If you change this to villaverde.gramscilab-ales.com, that should help your .htaccess file do what it’s supposed to do and let you see your site.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.