This is strange problem. @Admin can help you more here now.

Can you try it in a different computer?
and tell us the results?

I tried from the phone but still the same result

I’ll try to remove the domain and add it again, maybe it will work.

didn’t work :rofl:

mine took whole 2 days once… keep patience it will work out…

Yea, ihave the same problem, after getting my ssl certificate from infinityfree themselves, i cant install it. i get a private key not matching certificate error

i meant a similar problem

Only Admin can check this.
Wait for some time


@Admin can you help here

I just tried to setup the CNAME records for you, and didn’t encounter any issues.

Your problem is definitely not the same and I wouldn’t argue it’s not even similar. It’s in the same category, yes, but that doesn’t warrant hijacking a topic.

So please create a new topic, fill in the topic template and describe the issue there.


thank you

Thank you for sharing that video . Very easy to follow it

2 posts were merged into an existing topic: Ssl part 2

did you first uploaded private key and then the certificate??

if you have not done that do that one by one. you can’t upload both the keys at the same time or first certificate and then private key…

so first upload private key you got from the provider and then certificate.

friends, I wrote the information of the ssl certificate and clicked the install button, the page has been renewed. I have to wait now, what should I do? I tried a couple of times and I got an error because I wrote the wrong certificate. This time nothing happened, just the page was renewed, the confirmation letter did not come.

Website URL please?