SSL Problems

Hi all. I need your help please. My URL is thaivillagept.com and I’m new to this :frowning:

I’ve tried pretty much everything trying to activate the SSL and have the green lock button but to no avail. I even tried uninstalling wordpress to start over but even now when i try adding url with Https:// in the new WP install, it says Trusted SSL certificate was not found.

I have the SSL active from Infinityfree but I’m not sure what else I need to do. When I click to check the SSL Certificate status on infinity page, it shows Status as Verified. But when I click to expand, Step 1 and 2 seem ok but at “Step 3: Install the SSL certificate” it says Not using free SSL in yellow in the Status bar.

Things I have tried:
-redirecting to https by forcing all traffic using .htaccess in files.
-removing all content I had on the site that linked http and not https urls.
-Installing SSL plugins on my site but still no green lock,-
-running through many suggestions on this forum but pretty sure I might be missing something basic

Or the black lock button is all I can get? I’m confused as the instructions suggest if I had done everything correct, I would be able to see the green padlock with the site url.

Thanks in advance, any help would be appreciated

Welcome @thaifoodpt :slightly_smiling_face: I clicked on the link to your site and went to an http URL, on that page I clicked on Archives April 2020, that URL is https. I clicked on the lock and it showed the information below.
image

Your SSL shows Cloudflare not InfinityFree, and you need all URL’s on your site driven to https.
image
Here’s a knowledge base article that will help
https://infinityfree.net/support/how-to-force-all-traffic-to-https/

4 Likes

Firefox will only show a black lock, try the Waterfox browser, it does show a green lock on an https SSL site.

I changed the URL to https:// thaivillagept. com/ in the address bar and went to the https site, to me this shows all traffic isn’t being forced to https.

4 Likes

Hi Steve. Thanks for the quick response. I tried rechecking through the redirects yesterday but kept getting Bad Gateway error like many others so couldn’t reply.

So I went through everything again as you said, checked with Dr.link website and double checked all http urls and in the end ended up deleting all WP again and everything with it, even the SSL certificate and all. Re-issued SSL with new DNS entries, waited for the certificate and now all seems good. So I went on install fresh WP and it lets me select https url for my website (yayy), BUT…

The site wont load on admin… So I have a fresh copy of WP and everything seems to be good, only problem is it keeps getting redirect error on the wp-admin. normal site link works ok, but when i try to go on admin page it freezes and gives the error after a while.

This page isn’t working

thaivillagept.com redirected you too many times.

ERR_TOO_MANY_REDIRECTS

:((

also I checked the .htaccess file as well to see if the changes there made any difference but those changes are all gone after the fresh install of WP anyways.

I used a WP plugin called Really Simple SSL to drive all traffic to https on a WP site I had, you might give it a try, it worked fine for me.

I’ve heard of a user or two that had problems with that plugin causing errors on their site. Be aware of a possible problem with it, but you’re having problems right now, that plugin may clear up the SSL issue.

4 Likes

Since you’re using Cloudflare and WordPress, maybe you can check this article to configure your website correctly:

https://infinityfree.net/support/wordpress-and-cloudflare-flexible-ssl/

4 Likes

Hi, Thank you again for the replies. Makes us newbies life much easier with help from you guys! :slight_smile:

So after the redirect-looping my account was suspended for surpassing entry process limit, but after the 20hrs I did go through the recommendations and now all seems good. Changed the url and home from https to http, and once site was running I installed Simple SSL and the site shows as secured now. Thanks!

Only thing I couldn’t understand was how to check if the settings on my Cloudflare are set to flexible or full. I know the site is working now and I never changed Cloudflare settings so should be on default anyways. But I came across this suggestion before as well in the research and couldn’t figure out how to access or view those settings.

On the Cloudflare tab in configurations it only gives me the option to enable or disable. And on SSL/TSL tab it just has the option the put Keys and Certificate codes. No overview or Edge certificate tab that I could find. Was this changed in some recent updates to account permissions?

Thanks for the help again

1 Like

The default settings in Cloudflare are all fine. But some people start messing with settings like SSL modes and automagic “fixing” features in the hopes of getting their website to work. Touching settings you don’t understand or know what to do with tends to just make things worse.

When you enabled Cloudflare, an account was created for you at Cloudflare. You should have received an email from Cloudflare with more information, but you can also do a password reset at Cloudflare to gain access to your account there.

2 Likes

Perfect. Now it all makes more sense. Thanks!

One last thing while I have you here please, would you advise to keep the passwords for infinity account / cloudflare / FTP etc etc the same as they are (site generated) ? Or would you recommend to change them with all different and strong passwords?

A hosting account password is always the same for the control panel, FTP, database, etc. The default for this is a strong, randomly generated password. You’re free to set your own password, but a randomly generated password is most secure.

The client area enforces strong passwords, and ensures they are (reasonably) unique by checking that none of your other accounts or your client area profile have the same password.

For the Cloudflare account, I would recommend setting a different password, because password reuse is bad.

2 Likes

Sounds good to me, done.

That should be it (at least for now :smiley: ) Thanks again guys for all the info!! till next time, TC!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.