SSL Problems

Hello, I hope all is well…

We have an SSL certificate, all we need to do now is install it in the control panel, but we have a product key, and a certificate, yet when we click upload certificate, it says error?? When we add the key, then generate a CSR, and then add the certificate, it says they are not the same??

It;s all very strange, please can you advise??

We cannot get the control panel to accept it…

It is in the control panel, set all we see is this?

Do we have to keep going back every three months, or what??



You have only to upload the Private Key and the certificate from the SSL certificate page in the hosting account, without need to generate another Private Key and CSR, as the problem of installing directly the SSL certificate without generating first another Private Key and CSR was already solved.


Yeh I suused it, I was generating a new key and not uploading… It is saying it is on there now, but for less than three months, how do I get a longer one??

Now I am getting this…

For me SSL for your domain works now. If your SSL checker doesn’t detect your SSL certificate well, I would suggest using this one or a Chrome incognito tab to check whether SSL works for your domain.


Let’s Encrypt certificates are always valid for three months, not longer. The expiration warning should only be shown within 30 days from expiration. The fact that it’s shown on your domain is an error, which should be fixed now.


Hello Admin, ah I see, thanks for the clarification… So I just need to request one every three months or so, yes…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.