SSL not working

Blog.coozywana.ga

(please specify the website or account you are asking about)

Error Message

The connection for this site is not secure

www.blog.coozywana.ga uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Hide details

Unsupported protocol

The client and server don’t support a common SSL protocol version or cipher suite.

Other Information

(other information and details relevant to your question)

You need to set your Wordpress url to https without the www subdomain for this error to go away.

2 Likes

But last time it worked

Please share your Cloudflare SSL settings

Please note that Cloudflare’s Universal SSL only works for first level subdomains. So blog.coozywana.ga, forum.coozywana.ga and shop.coozywana.ga will work, but www.blog.coozywana.ga, eu.shop.coozywana.ga, etc. will not.

This is because Cloudflare uses a wildcard SSL certificate for your base domain coozywana.ga, and wildcard SSL certs only work for direct subdomains.

You could disable Cloudflare on the second level subdomain and install an SSL certificate on our hosting directly (you can request an SSL certificate that protects both blog.coozywana.ga and www.blog.coozywana.ga). But if I were you, I would just not use the domain www.blog.coozywana.ga and publish the blog on blog.coozywana.ga instead.

6 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.