SSL Certificate not Working For GoGetSSL

Username (e.g. epiz_XXX) or Website URL

epiz_31948732
(please specify the website or account you are asking about)
https://www.blueroadtravels.com/

Error Message

I’m trying to add GoGetSSL services to my domain however I still get “not ready” even after adding record name and destination to CNAME.
(please share the FULL error message you see)

Other Information

(other information and details relevant to your question)

Me too.

SSL certificate error: The order got stuck at the provider or took too long to complete. Please try again later or try a different provider.

am i related to this issue now @admin?

How long have you been waiting? GoGetSSL can take half an hour to issue your certificate under normal circumstances, and a few hours if you’re unlucky.

Nope, still not related.

The title clearly says “For GoGetSSL”. You can only get that error if you were using Let’s Encrypt or ZeroSSL, which use a different validation process than GoGetSSL.

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.