SSL Certificate Install Help

I got this error “The certificate uploaded is NOT for the domain name …” while I took a SSL certificate in SSLforfree.com. Except the CA bundle, I copied and pasted the Private Key and Certificate into 2 box in SSL/TLS tab. I also tried to use other SSL vendor parties, but that error still appeared. Please help me in installing SSL certificate to my domain.

You have the step of opening the SSL/TLS tab right. Afterwards, you paste the private key into the box labeled “Private Key”, then click “Upload Key”. Afterwards, you take your certificate, and paste it into the box labeled “Certificate”, NOT “Certificate Signing Request”. Afterwards, click “Upload”. It should have no errors then, and if it does, then it’s probably a problem with your certificate or the way you uploaded it. If it successfully uploads, then within a few hours, your certificate should start working.

Thank you. I got it. Now how can I change the domain from http to https.

null
i followed this , still no headway

I’m not good at IT. I received this notice “To recieve emails on the email address you will need to set the MX record for your domain name to mx.epizy.com”. How can I set MX records ?

@VictorCV said:
I’m not good at IT. I received this notice “To recieve emails on the email address you will need to set the MX record for your domain name to mx.epizy.com”. How can I set MX records ?

This article describes more about setting MX records: https://infinityfree.net/support/how-to-set-your-mx-record

@VictorCV said:
I’m not good at IT. I received this notice “To recieve emails on the email address you will need to set the MX record for your domain name to mx.epizy.com”. How can I set MX records ?

To redirect to HTTPS for your certificate, add an .htaccess file to your “htdocs” folder or edit your current one if you have one, and put this in it:
RewriteEngine On RewriteCond %{HTTP:X-Forwarded-Proto} =http RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

Also, do NOT name the file anything. It needs to be named just plain “.htaccess”, otherwise it WILL NOT WORK.