Site is not working..

My site: http://social-central.rf.gd/ is not responding. I added files and removed them Nothing changed. Is there a server upgrade or something?

Nervermind it works now. Had to close the account for about 30 mins to make it work.

NEVERMIND IT STILL NOT RESPONDING…

I’d be happy to check it, but that’s not really an option if the account has already been closed.

Okay. Ill io> @Admin said:

I’d be happy to check it, but that’s not really an option if the account has already been closed.

Okay its opening. I think it will take a min. The issue is when i go to the site i rarely will get the page im looking for if it does come on and i click something on the header or something else it gives me this error Screenshot - 3c38d27f235e81bc33572323e665c174 - Gyazo

It also takes forever for that error to load and the site (if it works)

It works now thank you for helping me!

Nervermind its broken again…

@Admin said:
I’d be happy to check it, but that’s not really an option if the account has already been closed.

The site broke again… Can you help? its giving me this again Screenshot - 3c38d27f235e81bc33572323e665c174 - Gyazo

Try to set it to another domain.
I had the same problem before.
Then i did that and it got fixed.

social-central.rf.gd is down for me as well, I’ve notified the server admins to take a look at it.

The issue was by a DDoS attack on the IP address. It takes a while for the DDoS filter to kick in and stop the attack, which caused some outages in between. If this keeps happening, please let me know so we can step up the protection.