Sending email through WP Mail SMTP

I tried to set up wp SMTP mail using TLS, but my website still can’t send an email and show me notice

Could not connect to the SMTP host.

This means your web server was unable to connect to mail.fhanafi.my.id.

is there anyone who can help me to check SMTP from another InfinityFree hosting?

You can use the following configuration to connect with my mail server

SMTP host: mail.fhanafi.my.id
SMTP port : 465 (TLS) or 587 (STARTTLS)
username : [email protected]
password : HIDDEN BY MOD

Thanks

Hello there,

Where did you get that SMTP details? Is that an InfinityFree SMTP details or an external SMTP details from a 3rd party?

Just for your information, InfinityFree does not provide free SMTP in fact the whole Email service has already been deprecated and discontinued a while ago but you can still use external email services like Zoho.

1 Like

Hi

Actually, I use my own external SMTP server :slightly_smiling_face:

yes I know about that :cry:, previously I use that service too :hugs:

Oh yeah sorry I just noticed this:

You did specify which SMTP server are you talking about.

Does your SMTP have a trusted SSL/TLS certificate installed already?
Also you can try using different ports like port 25.

yes, my SMTP Server have trusted SSL, i use this SMTP for other website and work normally

I already tested with port 465 and 587, both are failed…
and for outgoing mail i just use 465 and 587

Regards

Well since here is the only place where your SMTP server does not work, I can only conclude 2 things:

  1. Incorrect SMTP details and configuration
  2. Incompatible with the free hosting servers which I don’t see any likely reason why it should be incompatible

sorry I just could not reply because a few days ago there was another job

Can you try to connect/setting SMTP with my SMTP server configuration, or let someone see the SMTP password in this post? so maybe someone can test on their :sweat_smile:

because I need to send email from my Wordpress on Infinityfree :slightly_smiling_face:

Maybe try to add these SMTP options (adapting the variable you used on your code to define the PHPMailer object) onto your code:

$mail->SMTPOptions = array(
    'ssl' => array(
        'verify_peer' => false,
        'verify_peer_name' => false,
        'allow_self_signed' => true
    )
);

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.