Russell E. Willis

Attention: InfinityFree.com forum:
I have a free account with InfinityFree.com, I am using a custom domain name, and I have just successfully uploaded my web project file to the InifnityFree.com ftp site for my account. What is the next step to take so that I can view my web project on my website ( so that my website will be public )? Thank you ( see Colossians 3:15, for example ) for your help. Keep in touch.

Sincerely in Christ,
Russell E. Willis
P.S. - Please read Proverbs 23:23.

Nothing! If you added the domain to your account and uploaded your files to the right directory, you’re all set.

I checked your website and it looks like the file you uploaded was not uploaded to the correct directory (you’ll want to upload a file called index.php or index.html directly to the htdocs folder).

Also, when visiting the website again, please make sure you visit infinityfree.net and not infinityfree.com ;).

Attention: Admin:
Thank you ( see Colossians 3:15, for example ) for your help. Yesterday, I accidentally deleted the “index2.html” file, in the htdocs folder, that was included with my free account. I hope this will not cause a problem for me. Keep in touch.

Sincerely in Christ,
Russell E. Willis
P.S. - Please read Proverbs 23:23.

Attention: Admin:
I have one more question. I have uploaded my .html file ( named “index.htm” ) and the .jpg file ( to be included in the .html file ) to the “htdocs” folder. However, when I type my domain name ( named “theholybible1.ga” ) into the address bar of the Chrome web browser, I receive a gray web page with the two above-mentioned files shown in a directory listing. When I click on the link, in the directory listing, for the “index.htm” file, my web page appears in the web browser without the .jpg image in it. I was under the impression that when I successfully uploaded my files to the “htdocs” directory, all I would have to do is type my domain name in the address bar of the web browser, and my web site could be viewed with the correct formatting. What am I doing wrong? Thank you ( see Colossians 3:15, for example ) for your help. Keep in touch.

Sincerely in Christ,
Russell E. Willis
P.S. - Please read Proverbs 23:23.
P.P.S. - I created a project file ( named “The_Holy_Bible_1.synw-proj” ) in SynWrite ( version 6.40.2770 ), and am wondering if there is some way to save the project file as an .html file, and if that is necessary before uploading it to my free infinityFree.net account.

By default, the server will only look for files called index.html or index.php. To make you website work you can do one of two things:

  • Rename index.htm to index.html.
  • Add a file to your htdocs folder with the name .htaccess and the contents DirectoryIndex index.php index.html index.htm. This will make the server load the index.htm file as the default file for the directory.

Attention: Admin:
Thank you ( see Colossians 3:15, for example ) very much. The first option you suggested in your previous response solved my problem. My web page now loads automatically when I type in the domain name ( named “theholybible1.ga” ) in the address bar of a web browser, and when I launch my web site ( named “TheHolyBible” ) from within Internet Information Services ( IIS ) Manager 10 ( in Windows 10 ). Keep in touch.

Sincerely in Christ,
Russell E. Willis
P.S. - Please read Proverbs 23:23.