Problem with adding SSL

I enabled cloudfare in cpanel. And I wanted to enable SSL. Per tutorial, I added CNAME records in cpanel, and waited ~24 hours to refresh status. But I still get this error when want to refresh status of SSL: The required CNAME record could not be found. Please note that DNS changes can take up to 24 hours to take effect.

Can you help me please?

Hello there,

You must add those CNAME records directly on the Cloudflare Dashboard since you’re using Cloudflare and you’ll have to wait for a few minutes to a few hours until those newly set CNAME records will propagate.

1 Like

I already have enabled CloudFare via cpanel of this “hosting”. And added cname records in option of panel.

Our Cloudflare integration breaks many other features, which includes custom CNAME records.

On the other hand, you could wonder how big of a problem this is. After all, Cloudflare already provides HTTPS for your website, so you can use Cloudflare and their Flexible SSL system and skip installing an SSL certificate on your hosting account.

If you do want that, you’ll have to forego our Cloudflare integration and sign up with Cloudflare directly to use their nameservers.


I had to point domain to infinityfree NS, no cloudfare. Now works. Thank you!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.