New contents doesn't appear on my web page if not refresh the page

Hi friends;

my web site: www.teknovari.rf gd.

I used this code below in my index and categories.

But new contents and topics doesn’t appear on my web page if not refresh the page.

How i can solve this problem?

Thanks a lot.
Best regards.

Isn’t that how browsers and websites are supposed to work? Unless you mean something else by ‘refresh’

I add new content to my website.
Then I enter to my web site with Opera, Firefox or Chrome for testing.
But my new content doesn’t appear .
This is not normal.

Our servers enforce quite strong caching by default. In most cases, this reduces server usage for you and improves speed for your visitors. This is done on static HTML pages because they don’t change very often.

You can disable the caching with .htaccess rules if you want, but know that this will negatively impact your hits usage and the performance of your site.

4 Likes

Thank you very much.

I don’t know how can I disable the caching with .htaccess rules.

I tried codes link below. I put new .htacess file in htdocs folder. But problem continues.

https://stackoverrun.com/tr/q/783027

How can I disable the caching with .htaccess rules.

Please note that any change to caching settings only affect assets which are retrieved after the changes are made.

If some visits your website and caches it for 24 hours, one hour later you disable the caching and the visitor comes back an hour after that, they won’t see the new contact. That’s because the visitors browser still has the original cache which the browser believes is still valid for 22 hours, so the browser won’t check the sever again.

So please clear your cache first and then check if your changes have taken effect. Or check the Network tab in your browser to make sure the correct caching headers are sent from the server.

4 Likes

I used below codes in .htaccess file.
Problem was solved.
But my website loads slowly as you told.


Header set Cache-Control "no-cache, no-store, must-revalidate" Header set Pragma "no-cache" Header set Expires 0

<FilesMatch “.(css|flv|gif|htm|html|ico|jpe|jpeg|jpg|js|mp3|mp4|png|pdf|swf|txt)$”>

ExpiresActive Off


FileETag None
Header unset ETag
Header unset Pragma
Header unset Cache-Control
Header unset Last-Modified
Header set Pragma “no-cache”
Header set Cache-Control “max-age=0, no-cache, no-store, must-revalidate”
Header set Expires “Thu, 1 Jan 1970 00:00:00 GMT”

It loads slowly because you’ve disabled cache.

3 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.